summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn J. Ellis <jje@gentoo.org>2003-08-16 08:53:14 +0000
committerJohn J. Ellis <jje@gentoo.org>2003-08-16 08:53:14 +0000
commitc03b1265c5fa400bd6f66a1952f5f6477e4b7e75 (patch)
tree92ee363486d23de4ec9699c398f7016259600d5f /media-sound/pd/pd-0.35.0-r2.ebuild
parentVersion bump, tk/tcl version fixes, updates. See #23187. (diff)
downloadgentoo-2-c03b1265c5fa400bd6f66a1952f5f6477e4b7e75.tar.gz
gentoo-2-c03b1265c5fa400bd6f66a1952f5f6477e4b7e75.tar.bz2
gentoo-2-c03b1265c5fa400bd6f66a1952f5f6477e4b7e75.zip
Version bump, tk/tcl version fixes, updates. See #23187.
Diffstat (limited to 'media-sound/pd/pd-0.35.0-r2.ebuild')
-rw-r--r--media-sound/pd/pd-0.35.0-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-sound/pd/pd-0.35.0-r2.ebuild b/media-sound/pd/pd-0.35.0-r2.ebuild
new file mode 100644
index 000000000000..039125163316
--- /dev/null
+++ b/media-sound/pd/pd-0.35.0-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pd/pd-0.35.0-r2.ebuild,v 1.1 2003/08/16 08:53:07 jje Exp $
+
+# Miller Puckette uses nonstandard versioning scheme that we have to crunch
+MY_P=`echo ${P} | sed 's/\.\([0-9]\+\)$/-\1/'`
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="real-time music and multimedia environment"
+HOMEPAGE="http://www-crca.ucsd.edu/~msp/software.html"
+SRC_URI="http://www-crca.ucsd.edu/~msp/Software/${MY_P}.linux.tar.gz"
+
+LICENSE="BSD | as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X alsa"
+
+DEPEND="=dev-lang/tcl-8.3*
+ =dev-lang/tk-8.3*
+ alsa? ( >=media-libs/alsa-lib-0.9.0_rc2 )
+ X? ( x11-base/xfree )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S} || die
+ epatch ${FILESDIR}/${PF}.patch
+
+ cd src || die
+ autoconf || die
+}
+
+src_compile() {
+ cd src
+ econf \
+ `use_enable alsa` \
+ `use_with X x` \
+ `use_enable debug` \
+ || die "./configure failed"
+ emake || die "parallel make failed"
+}
+
+src_install() {
+ cd src
+ make DESTDIR=${D} install || die "install failed"
+}