summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-01-14 17:02:18 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-01-14 17:02:18 +0000
commitb144a26de55ac1d855316793b04bcf399882cab7 (patch)
treee161cf7aabb049c138d7c89617c6e138159ed39c /media-sound/museseq
parentCosmetic fix for java-osgi.eclass. (diff)
downloadgentoo-2-b144a26de55ac1d855316793b04bcf399882cab7.tar.gz
gentoo-2-b144a26de55ac1d855316793b04bcf399882cab7.tar.bz2
gentoo-2-b144a26de55ac1d855316793b04bcf399882cab7.zip
Add pkgconfig dependency for the Evil Compile Person <bugs@dev.gentooexperimental.org>, partially resolves bug #205616. Quote a few variables on the way.
(Portage version: 2.1.4)
Diffstat (limited to 'media-sound/museseq')
-rw-r--r--media-sound/museseq/ChangeLog11
-rw-r--r--media-sound/museseq/museseq-0.6.2-r1.ebuild30
-rw-r--r--media-sound/museseq/museseq-0.7.1.ebuild14
-rw-r--r--media-sound/museseq/museseq-0.7.2_pre5.ebuild16
-rw-r--r--media-sound/museseq/museseq-0.8.1-r1.ebuild14
-rw-r--r--media-sound/museseq/museseq-0.9_pre2.ebuild5
6 files changed, 49 insertions, 41 deletions
diff --git a/media-sound/museseq/ChangeLog b/media-sound/museseq/ChangeLog
index 7f581b996594..60603b69dd65 100644
--- a/media-sound/museseq/ChangeLog
+++ b/media-sound/museseq/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/museseq
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/ChangeLog,v 1.48 2007/04/15 11:21:22 aballier Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/ChangeLog,v 1.49 2008/01/14 17:02:18 chainsaw Exp $
+
+ 14 Jan 2008; Tony Vroon <chainsaw@gentoo.org> museseq-0.6.2-r1.ebuild,
+ museseq-0.7.1.ebuild, museseq-0.7.2_pre5.ebuild, museseq-0.8.1-r1.ebuild,
+ museseq-0.9_pre2.ebuild:
+ Add pkgconfig dependency for the Evil Compile Person
+ <bugs@dev.gentooexperimental.org>, partially resolves bug #205616. Quote a
+ few variables on the way.
15 Apr 2007; Alexis Ballier <aballier@gentoo.org>
+files/museseq-0.9_pre2-asneeded.patch, museseq-0.9_pre2.ebuild:
diff --git a/media-sound/museseq/museseq-0.6.2-r1.ebuild b/media-sound/museseq/museseq-0.6.2-r1.ebuild
index 8299052faa51..1338c6b0d8e4 100644
--- a/media-sound/museseq/museseq-0.6.2-r1.ebuild
+++ b/media-sound/museseq/museseq-0.6.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.6.2-r1.ebuild,v 1.14 2007/06/26 02:14:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.6.2-r1.ebuild,v 1.15 2008/01/14 17:02:18 chainsaw Exp $
IUSE="jack fluidsynth ladcca doc alsa"
@@ -28,14 +28,14 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i "s/HAVE_JACK_JACK_H/HAVE_JACK/" widgets/audioconf.cpp
sed -i "/#include <alsa\\/asoundlib.h>/i\\#define ALSA_PCM_OLD_HW_PARAMS_API 1\\" driver/alsaaudio.cpp
- epatch ${FILESDIR}/${P}-fPIC.patch
- epatch ${FILESDIR}/${P}-int2ptr.patch
- epatch ${FILESDIR}/${P}-memory.patch
- epatch ${FILESDIR}/${P}-drumport.patch
- epatch ${FILESDIR}/${P}-gcc34.patch
+ epatch "${FILESDIR}/${P}-fPIC.patch"
+ epatch "${FILESDIR}/${P}-int2ptr.patch"
+ epatch "${FILESDIR}/${P}-memory.patch"
+ epatch "${FILESDIR}/${P}-drumport.patch"
+ epatch "${FILESDIR}/${P}-gcc34.patch"
}
src_compile() {
@@ -49,7 +49,7 @@ src_compile() {
local stylesheets="$(echo /usr/share/sgml/docbook/dsssl-stylesheets-*)"
myconf="${myconf} --with-docbook-stylesheets=${stylesheets}"
fi
- Xeconf ${myconf} || die "configure failed"
+ Xeconf "${myconf}" || die "configure failed"
### borrowed from kde.eclass #
#
@@ -57,8 +57,8 @@ src_compile() {
# this is a fake homedir that is writeable under the sandbox,
# so that the build process can do anything it wants with it.
REALHOME="$HOME"
- mkdir -p $T/fakehome/.kde
- mkdir -p $T/fakehome/.qt
+ mkdir -p "$T/fakehome/.kde"
+ mkdir -p "$T/fakehome/.qt"
export HOME="$T/fakehome"
#addwrite "${QTDIR}/etc/settings"
# commented this out, proper fix is need-qt 3 from
@@ -76,15 +76,15 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc README README.softsynth SECURITY TODO
- mv ${D}/usr/share/muse/html ${D}/usr/share/doc/${PF}/html
- dosym /usr/share/doc/${PF}/html /usr/share/muse/html
+ mv "${D}/usr/share/muse/html" "${D}/usr/share/doc/${PF}/html"
+ dosym "/usr/share/doc/${PF}/html" /usr/share/muse/html
use doc && dohtml doc/*
# Name conflict with media-sound/muse. See bug #34973
- mv ${D}/usr/bin/muse ${D}/usr/bin/lmuse
+ mv "${D}/usr/bin/muse" "${D}/usr/bin/lmuse"
if [ ! -f /usr/bin/muse -o -L /usr/bin/muse ]; then
dosym /usr/bin/lmuse /usr/bin/muse
fi
diff --git a/media-sound/museseq/museseq-0.7.1.ebuild b/media-sound/museseq/museseq-0.7.1.ebuild
index 3e05da59f55a..e1a4089553c1 100644
--- a/media-sound/museseq/museseq-0.7.1.ebuild
+++ b/media-sound/museseq/museseq-0.7.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.7.1.ebuild,v 1.9 2007/07/11 19:30:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.7.1.ebuild,v 1.10 2008/01/14 17:02:18 chainsaw Exp $
inherit kde-functions virtualx eutils toolchain-funcs
@@ -29,23 +29,23 @@ DEPEND="$(qt_min_version 3.2)
ladcca? ( >=media-libs/ladcca-0.4.0 )"
src_compile() {
- cd ${WORKDIR}/${MY_P}
+ cd "${WORKDIR}/${MY_P}"
local myconf
myconf="--disable-suid-build" # instead, use CONFIG_RTC and realtime-lsm
use ladcca || myconf="${myconf} --disable-ladcca"
use debug && myconf="${myconf} --enable-debug"
export LD="$(tc-getLD)"
- Xeconf ${myconf} || die "configure failed"
+ Xeconf "${myconf}" || die "configure failed"
emake || die
}
src_install() {
- cd ${WORKDIR}/${MY_P}
- make DESTDIR=${D} install || die "install failed"
+ cd "${WORKDIR}/${MY_P}"
+ make DESTDIR="${D}" install || die "install failed"
dodoc AUTHORS ChangeLog NEWS README SECURITY README.*
- mv ${D}/usr/bin/muse ${D}/usr/bin/museseq
+ mv "${D}/usr/bin/muse" "${D}/usr/bin/museseq"
}
pkg_postinst() {
diff --git a/media-sound/museseq/museseq-0.7.2_pre5.ebuild b/media-sound/museseq/museseq-0.7.2_pre5.ebuild
index 4f85ed3a744a..32d5ebc0e70c 100644
--- a/media-sound/museseq/museseq-0.7.2_pre5.ebuild
+++ b/media-sound/museseq/museseq-0.7.2_pre5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.7.2_pre5.ebuild,v 1.5 2007/01/14 00:35:09 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.7.2_pre5.ebuild,v 1.6 2008/01/14 17:02:18 chainsaw Exp $
inherit kde-functions virtualx eutils
@@ -31,12 +31,12 @@ DEPEND="$(qt_min_version 3.2)
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-rtctimerfix.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-rtctimerfix.patch"
}
src_compile() {
- cd ${WORKDIR}/${MY_P}
+ cd "${WORKDIR}/${MY_P}"
local myconf
myconf="--disable-suid-build" # instead, use CONFIG_RTC and realtime-lsm
use ladcca || myconf="${myconf} --disable-ladcca"
@@ -47,10 +47,10 @@ src_compile() {
}
src_install() {
- cd ${WORKDIR}/${MY_P}
- make DESTDIR=${D} install || die "install failed"
+ cd "${WORKDIR}/${MY_P}"
+ make DESTDIR="${D}" install || die "install failed"
dodoc AUTHORS ChangeLog NEWS README SECURITY README.*
- mv ${D}/usr/bin/muse ${D}/usr/bin/museseq
+ mv "${D}/usr/bin/muse" "${D}/usr/bin/museseq"
}
pkg_postinst() {
diff --git a/media-sound/museseq/museseq-0.8.1-r1.ebuild b/media-sound/museseq/museseq-0.8.1-r1.ebuild
index f0389148ed90..3465ead7323f 100644
--- a/media-sound/museseq/museseq-0.8.1-r1.ebuild
+++ b/media-sound/museseq/museseq-0.8.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.8.1-r1.ebuild,v 1.5 2007/02/04 21:37:03 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.8.1-r1.ebuild,v 1.6 2008/01/14 17:02:18 chainsaw Exp $
inherit kde-functions virtualx eutils
@@ -31,22 +31,22 @@ DEPEND="$(qt_min_version 3.2)
lash? ( media-sound/lash )"
src_compile() {
- cd ${WORKDIR}/${MY_P}
+ cd "${WORKDIR}/${MY_P}"
local myconf
myconf="--disable-suid-build" # instead, use CONFIG_RTC and realtime-lsm
use lash && myconf="${myconf} --enable-lash"
use lash || myconf="${myconf} --disable-lash"
use debug && myconf="${myconf} --enable-debug"
- Xeconf ${myconf} || die "configure failed"
+ Xeconf "${myconf}" || die "configure failed"
emake all || die
}
src_install() {
- cd ${WORKDIR}/${MY_P}
- make DESTDIR=${D} install || die "install failed"
+ cd "${WORKDIR}/${MY_P}"
+ make DESTDIR="${D}" install || die "install failed"
dodoc AUTHORS ChangeLog NEWS README SECURITY README.*
- mv ${D}/usr/bin/muse ${D}/usr/bin/museseq
+ mv "${D}/usr/bin/muse" "${D}/usr/bin/museseq"
}
pkg_postinst() {
diff --git a/media-sound/museseq/museseq-0.9_pre2.ebuild b/media-sound/museseq/museseq-0.9_pre2.ebuild
index e601316c146f..e646e55d6378 100644
--- a/media-sound/museseq/museseq-0.9_pre2.ebuild
+++ b/media-sound/museseq/museseq-0.9_pre2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.9_pre2.ebuild,v 1.3 2007/04/15 11:21:22 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/museseq/museseq-0.9_pre2.ebuild,v 1.4 2008/01/14 17:02:18 chainsaw Exp $
inherit kde-functions virtualx eutils
@@ -27,6 +27,7 @@ RDEPEND="$(qt_min_version 3.2)
lash? ( media-sound/lash )"
DEPEND="${RDEPEND}
+ dev-util/pkgconfig
doc? ( app-text/openjade
app-doc/doxygen
media-gfx/graphviz )"