summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-05-05 19:13:10 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-05-05 19:13:10 +0000
commit1ef642a9f6c9fc98f6636d25e06476395a5aba7c (patch)
treeb9252870a3fe26dda85d550409826c3ddeb6ad7e /media-sound/mumble
parentVersion bump; old (see upstream changelog); SRC_TEST love (diff)
downloadgentoo-2-1ef642a9f6c9fc98f6636d25e06476395a5aba7c.tar.gz
gentoo-2-1ef642a9f6c9fc98f6636d25e06476395a5aba7c.tar.bz2
gentoo-2-1ef642a9f6c9fc98f6636d25e06476395a5aba7c.zip
Add vanilla use flag and fixed the patch.
Thanks to Mikkel Krautz wrt bug #177167. (Portage version: 2.1.2.6)
Diffstat (limited to 'media-sound/mumble')
-rw-r--r--media-sound/mumble/ChangeLog7
-rw-r--r--media-sound/mumble/files/mumble-0.9.4-path.patch5
-rw-r--r--media-sound/mumble/mumble-0.9.4.ebuild6
3 files changed, 13 insertions, 5 deletions
diff --git a/media-sound/mumble/ChangeLog b/media-sound/mumble/ChangeLog
index 00f336a4bb53..6f70590187c0 100644
--- a/media-sound/mumble/ChangeLog
+++ b/media-sound/mumble/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mumble
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/ChangeLog,v 1.6 2007/05/01 20:37:52 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/ChangeLog,v 1.7 2007/05/05 19:13:10 drizzt Exp $
+
+ 05 May 2007; Timothy Redaelli <drizzt@gentoo.org>
+ files/mumble-0.9.4-path.patch, mumble-0.9.4.ebuild:
+ Add vanilla use flag and fixed the patch.
+ Thanks to Mikkel Krautz wrt bug #177167.
01 May 2007; Timothy Redaelli <drizzt@gentoo.org> mumble-0.9.4.ebuild:
Remove pch use flags since it does not work anymore. Force
diff --git a/media-sound/mumble/files/mumble-0.9.4-path.patch b/media-sound/mumble/files/mumble-0.9.4-path.patch
index 7462e91a04f1..1fc24f818c02 100644
--- a/media-sound/mumble/files/mumble-0.9.4-path.patch
+++ b/media-sound/mumble/files/mumble-0.9.4-path.patch
@@ -1,6 +1,6 @@
--- Database.cpp.orig 2006-11-25 12:13:13.745701315 +0100
+++ Database.cpp 2006-11-25 12:14:31.167122733 +0100
-@@ -37,10 +37,7 @@
+@@ -37,10 +37,10 @@
QStringList datapaths;
int i;
@@ -8,7 +8,10 @@
- datapaths << QDir::homePath();
- datapaths << qApp->applicationDirPath();
- datapaths << QDir::currentPath();
++ QDir dir;
++
+ datapaths << QDir::homePath() + "/.qt";
++ dir.mkpath (datapaths[0]);
bool found = false;
for(i = 0; (i < datapaths.size()) && ! found; i++) {
diff --git a/media-sound/mumble/mumble-0.9.4.ebuild b/media-sound/mumble/mumble-0.9.4.ebuild
index 999451e6dbc6..d5f1aed2c5b7 100644
--- a/media-sound/mumble/mumble-0.9.4.ebuild
+++ b/media-sound/mumble/mumble-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/mumble-0.9.4.ebuild,v 1.6 2007/05/01 20:37:52 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/mumble-0.9.4.ebuild,v 1.7 2007/05/05 19:13:10 drizzt Exp $
inherit eutils toolchain-funcs
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE=""
+IUSE="vanilla"
DEPEND="dev-libs/boost
=x11-libs/qt-4*
@@ -38,7 +38,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-path.patch
+ use vanilla || epatch "${FILESDIR}"/${P}-path.patch
}
src_compile() {