summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-17 09:58:38 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-17 09:58:38 +0000
commitd3aa062acdbb43b2e7f90fa4878f2f37a108669b (patch)
tree3958c36f6f20af83866eab37d3c27ffbb6207838 /media-sound/mpg321
parentia64 stable wrt security #220911 (diff)
downloadgentoo-2-d3aa062acdbb43b2e7f90fa4878f2f37a108669b.tar.gz
gentoo-2-d3aa062acdbb43b2e7f90fa4878f2f37a108669b.tar.bz2
gentoo-2-d3aa062acdbb43b2e7f90fa4878f2f37a108669b.zip
quoting
(Portage version: 2.1.5)
Diffstat (limited to 'media-sound/mpg321')
-rw-r--r--media-sound/mpg321/mpg321-0.2.10-r3.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/media-sound/mpg321/mpg321-0.2.10-r3.ebuild b/media-sound/mpg321/mpg321-0.2.10-r3.ebuild
index 37de91e42c36..2043cb2f0c06 100644
--- a/media-sound/mpg321/mpg321-0.2.10-r3.ebuild
+++ b/media-sound/mpg321/mpg321-0.2.10-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/mpg321-0.2.10-r3.ebuild,v 1.5 2008/05/17 08:48:35 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpg321/mpg321-0.2.10-r3.ebuild,v 1.6 2008/05/17 09:58:38 drac Exp $
inherit eutils
@@ -20,13 +20,13 @@ KEYWORDS="~alpha ~amd64 -mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# fix file descriptors leak (from Debian?)
- epatch ${FILESDIR}/${P}.diff
+ epatch "${FILESDIR}"/${P}.diff
# provide an User-Agent when requesting via HTTP
# By Frank Ruell, in FreeBSD PR 84898
- epatch ${FILESDIR}/${P}-useragent.patch
+ epatch "${FILESDIR}"/${P}-useragent.patch
}
src_compile() {
@@ -36,22 +36,22 @@ src_compile() {
}
src_install () {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
dodoc AUTHORS BUGS ChangeLog HACKING NEWS README README.remote THANKS TODO
}
pkg_postinst() {
# We create a symlink for /usr/bin/mpg123 if it doesn't already exist
- if ! [ -f ${ROOT}/usr/bin/mpg123 ]; then
- ln -s mpg321 ${ROOT}/usr/bin/mpg123
+ if ! [ -f "${ROOT}"usr/bin/mpg123 ]; then
+ ln -s mpg321 "${ROOT}"usr/bin/mpg123
fi
}
pkg_postrm() {
# We delete the symlink if it's nolonger valid.
- if [ -L "${ROOT}/usr/bin/mpg123" ] && [ ! -x "${ROOT}/usr/bin/mpg123" ]; then
- elog "We are removing the ${ROOT}/usr/bin/mpg123 symlink since it is no longer valid."
+ if [ -L "${ROOT}usr/bin/mpg123" ] && [ ! -x "${ROOT}usr/bin/mpg123" ]; then
+ elog "We are removing the ${ROOT}usr/bin/mpg123 symlink since it is no longer valid."
elog "If you are using another virtual/mpg123 program, you should setup the appropriate symlink."
- rm ${ROOT}/usr/bin/mpg123
+ rm "${ROOT}"usr/bin/mpg123
fi
}