summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-07-17 10:10:51 +0000
committerNick Hadaway <raker@gentoo.org>2003-07-17 10:10:51 +0000
commit52f51bddddb4baec795afa1a4635eaf9d8ea06e4 (patch)
tree487df33ce24482d14acd95de9460c01c5da1a682 /media-sound/mpd
parentNew ebuild. The next generation of mad (diff)
downloadgentoo-2-52f51bddddb4baec795afa1a4635eaf9d8ea06e4.tar.gz
gentoo-2-52f51bddddb4baec795afa1a4635eaf9d8ea06e4.tar.bz2
gentoo-2-52f51bddddb4baec795afa1a4635eaf9d8ea06e4.zip
New ebuild. :)
Diffstat (limited to 'media-sound/mpd')
-rw-r--r--media-sound/mpd/ChangeLog9
-rw-r--r--media-sound/mpd/Manifest3
-rw-r--r--media-sound/mpd/files/digest-mpd-0.8.11
-rw-r--r--media-sound/mpd/mpd-0.8.1.ebuild44
4 files changed, 57 insertions, 0 deletions
diff --git a/media-sound/mpd/ChangeLog b/media-sound/mpd/ChangeLog
new file mode 100644
index 000000000000..12366ac59d17
--- /dev/null
+++ b/media-sound/mpd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-sound/mpd
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/ChangeLog,v 1.1 2003/07/17 10:10:51 raker Exp $
+
+*mpd-0.8.1 (17 Jul 2003)
+
+ 17 Jul 2003; Nick Hadaway <raker@gentoo.org> mpd-0.8.1.ebuild:
+ New ebuild. Depends on the newer media-libs/{libmad,libid3tag}
+ rather than media-sound/mad
diff --git a/media-sound/mpd/Manifest b/media-sound/mpd/Manifest
new file mode 100644
index 000000000000..949310f72da9
--- /dev/null
+++ b/media-sound/mpd/Manifest
@@ -0,0 +1,3 @@
+MD5 c7076c364d6baeca26c6a83d88b49c06 mpd-0.8.1.ebuild 1047
+MD5 fd85617c8a07405f9dec0cebe8387ac9 ChangeLog 311
+MD5 584e630a8aba4c01febb8248c9f3247b files/digest-mpd-0.8.1 61
diff --git a/media-sound/mpd/files/digest-mpd-0.8.1 b/media-sound/mpd/files/digest-mpd-0.8.1
new file mode 100644
index 000000000000..706dd705fac4
--- /dev/null
+++ b/media-sound/mpd/files/digest-mpd-0.8.1
@@ -0,0 +1 @@
+MD5 6a2f169a7da376485bea876da4c61ba3 mpd-0.8.1.tar.gz 713410
diff --git a/media-sound/mpd/mpd-0.8.1.ebuild b/media-sound/mpd/mpd-0.8.1.ebuild
new file mode 100644
index 000000000000..06e5cb0baa6b
--- /dev/null
+++ b/media-sound/mpd/mpd-0.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mpd/mpd-0.8.1.ebuild,v 1.1 2003/07/17 10:10:51 raker Exp $
+
+IUSE="oggvorbis mad"
+
+DESCRIPTION="Music Player Daemon (mpd)"
+SRC_URI="http://mercury.chem.pitt.edu/~shank/${P}.tar.gz"
+HOMEPAGE="http://musicpd.sourceforge.net/"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="oggvorbis? ( media-libs/libvorbis )
+ mad? ( media-libs/libmad media-libs/libid3tag )
+ >=media-libs/flac-1.1.0
+ media-libs/libao
+ sys-libs/zlib"
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld"
+
+ use oggvorbis \
+ || myconf="${myconf} --disable-ogg --disable-oggtest \
+ --disable-vorbistest"
+ use mad \
+ || myconf="${myconf} --enable-mpd-mad --enable-mpd-id3tag"
+
+ econf ${myconf} || die "could not configure"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${S}
+ dobin mpd
+ dodoc mpdconf.example COMMANDS ChangeLog INSTALL README TODO UPGRADING
+}
+
+pkg_postinst() {
+ einfo "libao has issues with the ALSA drivers, please refer to the FAQ"
+ einfo "http://musicpd.sourceforge.net/faq.php"
+}