summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-12-01 10:24:59 +0000
committerTilman Klar <phoenix@gentoo.org>2002-12-01 10:24:59 +0000
commitaf86e142e7b2b3632e1b9d530c8e1e3397c45260 (patch)
tree0aab31746274da19cf3bcf2027019fcfd315ba06 /media-sound/lame
parentsmall fixes (diff)
downloadgentoo-2-af86e142e7b2b3632e1b9d530c8e1e3397c45260.tar.gz
gentoo-2-af86e142e7b2b3632e1b9d530c8e1e3397c45260.tar.bz2
gentoo-2-af86e142e7b2b3632e1b9d530c8e1e3397c45260.zip
Incorporated two patches. This closes bug #11194, thanks to Sebastian Droege <sebastian.droege@gmx.de> for the contribution.
Diffstat (limited to 'media-sound/lame')
-rw-r--r--media-sound/lame/ChangeLog8
-rw-r--r--media-sound/lame/files/digest-lame-3.93.0-r11
-rw-r--r--media-sound/lame/files/lame-3.93.0-gentoo.diff50
-rw-r--r--media-sound/lame/lame-3.93.0-r1.ebuild66
4 files changed, 124 insertions, 1 deletions
diff --git a/media-sound/lame/ChangeLog b/media-sound/lame/ChangeLog
index f7ca3ee45575..dbfd66aadafd 100644
--- a/media-sound/lame/ChangeLog
+++ b/media-sound/lame/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for media-sound/lame
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.8 2002/11/24 00:13:34 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/ChangeLog,v 1.9 2002/12/01 10:24:59 phoenix Exp $
+*lame-3.93.0 (23 Nov 2002)
+ 01 Dec 2002; phoen][x <phoenix@gentoo.org> lame-3.93.0-r1.ebuild,
+ files/lame-3.93.0-npsytunefix.diff, files/lame-3.93.0-q0fix.diff :
+ Incorporated the fixes from bug #11194. Thanks to Sebastian Droege
+ <sebastian.droege@gmx.de> for the contribution.
+
*lame-3.93.0 (23 Nov 2002)
23 Nov 2002; Spider <spider@gentoo.org> lame-3.93.0.ebuild :
diff --git a/media-sound/lame/files/digest-lame-3.93.0-r1 b/media-sound/lame/files/digest-lame-3.93.0-r1
new file mode 100644
index 000000000000..1184ed7afd05
--- /dev/null
+++ b/media-sound/lame/files/digest-lame-3.93.0-r1
@@ -0,0 +1 @@
+MD5 2c054c7eec1f966499d0945642bd8cba lame-3.93.0.tar.gz 1036360
diff --git a/media-sound/lame/files/lame-3.93.0-gentoo.diff b/media-sound/lame/files/lame-3.93.0-gentoo.diff
new file mode 100644
index 000000000000..8e3e88b0036e
--- /dev/null
+++ b/media-sound/lame/files/lame-3.93.0-gentoo.diff
@@ -0,0 +1,50 @@
+--- libmp3lame/lame.c.orig 2002-12-01 11:01:49.000000000 +0100
++++ libmp3lame/lame.c 2002-12-01 10:45:42.000000000 +0100
+@@ -20,7 +20,7 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
+-/* $Id: lame-3.93.0-gentoo.diff,v 1.1 2002/12/01 10:24:59 phoenix Exp $ */
++/* $Id: lame-3.93.0-gentoo.diff,v 1.1 2002/12/01 10:24:59 phoenix Exp $ */
+
+ #ifdef HAVE_CONFIG_H
+ # include <config.h>
+@@ -474,7 +474,7 @@
+ gfc->quantization = 1;
+ gfc->noise_shaping = 1; /* 2=usually lowers quality */
+ gfc->substep_shaping = 2;
+- gfc->noise_shaping_amp = 3;
++ gfc->noise_shaping_amp = 2;
+ gfc->noise_shaping_stop = 1;
+ gfc->use_best_huffman = 1; /* 2 not yet coded */
+ }
+--- libmp3lame/psymodel.c.orig 2002-12-01 11:02:47.000000000 +0100
++++ libmp3lame/psymodel.c 2002-12-01 10:45:42.000000000 +0100
+@@ -19,7 +19,7 @@
+ * Boston, MA 02111-1307, USA.
+ */
+
+-/* $Id: lame-3.93.0-gentoo.diff,v 1.1 2002/12/01 10:24:59 phoenix Exp $ */
++/* $Id: lame-3.93.0-gentoo.diff,v 1.1 2002/12/01 10:24:59 phoenix Exp $ */
+
+
+ /*
+@@ -1789,6 +1789,9 @@
+ }
+
+ /* 2001-07-13 */
++ thr[b] = Max(1e-6, ecb);
++
++ if (gfp->VBR == vbr_mtrh) {
+ thr[b] = Min( ecb, rpelev_s * gfc->nb_s1[chn][b] );
+ if (gfc->blocktype_old[chn>1 ? chn-2 : chn] == SHORT_TYPE ) {
+ thr[b] = Min( thr[b], rpelev2_s * gfc->nb_s2[chn][b] );
+@@ -1796,6 +1799,7 @@
+ thr[b] = Max( thr[b], 1e-37 );
+ gfc->nb_s2[chn][b] = gfc->nb_s1[chn][b];
+ gfc->nb_s1[chn][b] = ecb;
++ }
+ }
+ }
+ for ( sb = 0; sb < NBPSY_s; sb++ )
+
diff --git a/media-sound/lame/lame-3.93.0-r1.ebuild b/media-sound/lame/lame-3.93.0-r1.ebuild
new file mode 100644
index 000000000000..376894748a00
--- /dev/null
+++ b/media-sound/lame/lame-3.93.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lame/lame-3.93.0-r1.ebuild,v 1.1 2002/12/01 10:24:59 phoenix Exp $
+
+IUSE="gtk"
+
+inherit libtool base eutils
+MY_PV=`echo ${PV}|cut -d . -f -2`
+S=${WORKDIR}/lame-${MY_PV}
+DESCRIPTION="LAME Ain't an Mp3 Encoder"
+SRC_URI="mirror://sourceforge/lame/${P}.tar.gz"
+HOMEPAGE="http://www.mp3dev.org/mp3/"
+
+DEPEND="virtual/glibc
+ x86? ( dev-lang/nasm )
+ >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+# this release completely removed oggvorbis support as it was too outdated.
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+src_unpack() {
+ base_src_unpack unpack patch
+}
+
+src_compile() {
+ elibtoolize
+
+ local myconf=""
+ if [ "`use gtk`" ] ; then
+ myconf="${myconf} --enable-mp3x"
+ fi
+ if [ "${DEBUG}" ] ; then
+ myconf="${myconf} --enable-debug=yes"
+ else
+ myconf="${myconf} --enable-debug=no"
+ fi
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-shared \
+ --enable-nasm \
+ --enable-mp3rtp \
+ --enable-extopt=full \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ pkghtmldir=${D}/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc API COPYING HACKING PRESETS.draft LICENSE README* TODO USAGE
+ dohtml -r ./
+}
+