summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-11-06 16:53:05 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-11-06 16:53:05 +0000
commita9e81c1f0d2729643729958753a8aaf531d13fa4 (patch)
treea7e46287d36912801a38cc7eea1150e5ce674d75 /media-sound/kid3
parenttidy (diff)
downloadgentoo-2-a9e81c1f0d2729643729958753a8aaf531d13fa4.tar.gz
gentoo-2-a9e81c1f0d2729643729958753a8aaf531d13fa4.tar.bz2
gentoo-2-a9e81c1f0d2729643729958753a8aaf531d13fa4.zip
Forcing KDE support on, as kid3 cannot be configured without having the KDE libraries installed. Also fixes bug #111692.
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'media-sound/kid3')
-rw-r--r--media-sound/kid3/ChangeLog6
-rw-r--r--media-sound/kid3/kid3-0.6.ebuild26
2 files changed, 16 insertions, 16 deletions
diff --git a/media-sound/kid3/ChangeLog b/media-sound/kid3/ChangeLog
index ed67fd2ee271..1d1fd5f4f767 100644
--- a/media-sound/kid3/ChangeLog
+++ b/media-sound/kid3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/kid3
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.16 2005/11/05 20:07:00 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/ChangeLog,v 1.17 2005/11/06 16:53:05 greg_g Exp $
+
+ 06 Nov 2005; Gregorio Guidi <greg_g@gentoo.org> kid3-0.6.ebuild:
+ Forcing KDE support on, as kid3 cannot be configured without having the KDE
+ libraries installed. Also fixes bug #111692.
*kid3-0.6 (05 Nov 2005)
diff --git a/media-sound/kid3/kid3-0.6.ebuild b/media-sound/kid3/kid3-0.6.ebuild
index 3c04ad520566..5eca255c8c79 100644
--- a/media-sound/kid3/kid3-0.6.ebuild
+++ b/media-sound/kid3/kid3-0.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.1 2005/11/05 20:07:00 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/kid3/kid3-0.6.ebuild,v 1.2 2005/11/06 16:53:05 greg_g Exp $
-inherit kde-functions
+inherit kde
DESCRIPTION="A simple ID3 tag editor for QT/KDE."
HOMEPAGE="http://kid3.sourceforge.net/"
@@ -11,28 +11,24 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="flac kde musicbrainz vorbis"
+IUSE="flac musicbrainz vorbis"
-DEPEND="=x11-libs/qt-3*
- >=media-libs/id3lib-3.8.3
- kde? ( kde-base/kdelibs )
+DEPEND=">=media-libs/id3lib-3.8.3
vorbis? ( media-libs/libvorbis )
flac? ( media-libs/flac )
musicbrainz? ( media-libs/tunepimp )"
-set-kdedir 3
+need-kde 3
+
+# Support for the KDE libraries is optional,
+# but the configure step that detects them
+# cannot be avoided. So KDE support is forced on.
src_compile() {
- local myconf="$(use_with kde)
+ local myconf="--with-kde
$(use_with vorbis)
$(use_with flac)
$(use_with musicbrainz)"
- econf ${myconf} || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
+ kde_src_compile
}