summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-29 15:16:24 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-29 15:16:24 +0000
commit4a1516968127ac3a6839260def0ef22343d1ae42 (patch)
tree17a30e2f1ef3107f72c2a2a95e73cecc5cf037b6 /media-sound/grip
parentMoving net-www/mod_scgi to www-apache/mod_scgi (#81244). (diff)
downloadgentoo-2-4a1516968127ac3a6839260def0ef22343d1ae42.tar.gz
gentoo-2-4a1516968127ac3a6839260def0ef22343d1ae42.tar.bz2
gentoo-2-4a1516968127ac3a6839260def0ef22343d1ae42.zip
Fix warning, implicit declaration of built-in function strlen.
(Portage version: 2.1.3)
Diffstat (limited to 'media-sound/grip')
-rw-r--r--media-sound/grip/ChangeLog8
-rw-r--r--media-sound/grip/files/digest-grip-3.3.1-r13
-rw-r--r--media-sound/grip/files/grip-3.3.1-implicit-declaration.patch11
-rw-r--r--media-sound/grip/grip-3.3.1-r1.ebuild50
4 files changed, 71 insertions, 1 deletions
diff --git a/media-sound/grip/ChangeLog b/media-sound/grip/ChangeLog
index 94442f6325e3..c94edad1868a 100644
--- a/media-sound/grip/ChangeLog
+++ b/media-sound/grip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/grip
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.75 2007/06/20 19:47:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/ChangeLog,v 1.76 2007/07/29 15:16:24 drac Exp $
+
+*grip-3.3.1-r1 (29 Jul 2007)
+
+ 29 Jul 2007; Samuli Suominen <drac@gentoo.org>
+ +files/grip-3.3.1-implicit-declaration.patch, +grip-3.3.1-r1.ebuild:
+ Fix warning, implicit declaration of built-in function strlen.
20 Jun 2007; Raúl Porcel <armin76@gentoo.org> grip-3.3.1.ebuild:
alpha/ia64 stable wrt #136137, thanks to Tobias Klausmann for testing
diff --git a/media-sound/grip/files/digest-grip-3.3.1-r1 b/media-sound/grip/files/digest-grip-3.3.1-r1
new file mode 100644
index 000000000000..9b8829e6ab88
--- /dev/null
+++ b/media-sound/grip/files/digest-grip-3.3.1-r1
@@ -0,0 +1,3 @@
+MD5 4b4233999b9f2bc85c711092553ea9aa grip-3.3.1.tar.gz 812562
+RMD160 ec523457b06505e6ec98605badcacd5085599676 grip-3.3.1.tar.gz 812562
+SHA256 d46394a1062ed066f9c633b010fd1059e63d9ed791bbb7a85bc6567cf0fd66fd grip-3.3.1.tar.gz 812562
diff --git a/media-sound/grip/files/grip-3.3.1-implicit-declaration.patch b/media-sound/grip/files/grip-3.3.1-implicit-declaration.patch
new file mode 100644
index 000000000000..ad8a83182909
--- /dev/null
+++ b/media-sound/grip/files/grip-3.3.1-implicit-declaration.patch
@@ -0,0 +1,11 @@
+diff -ur grip-3.3.1.orig/src/status_window.c grip-3.3.1/src/status_window.c
+--- grip-3.3.1.orig/src/status_window.c 2004-04-15 21:21:37.000000000 +0300
++++ grip-3.3.1/src/status_window.c 2007-07-29 18:08:48.000000000 +0300
+@@ -23,6 +23,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <unistd.h>
++#include <string.h>
+ #include <fcntl.h>
+ #include <vte/vte.h>
+ #include "status_window.h"
diff --git a/media-sound/grip/grip-3.3.1-r1.ebuild b/media-sound/grip/grip-3.3.1-r1.ebuild
new file mode 100644
index 000000000000..69194ba6416e
--- /dev/null
+++ b/media-sound/grip/grip-3.3.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/grip/grip-3.3.1-r1.ebuild,v 1.1 2007/07/29 15:16:24 drac Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="GTK+ based Audio CD Player/Ripper."
+HOMEPAGE="http://www.nostatic.org/grip"
+SRC_URI="mirror://sourceforge/grip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls vorbis"
+
+RDEPEND=">=x11-libs/gtk+-2.2
+ x11-libs/vte
+ media-sound/lame
+ media-sound/cdparanoia
+ >=media-libs/id3lib-3.8.3
+ >=gnome-base/libgnomeui-2.2.0
+ >=gnome-base/orbit-2
+ net-misc/curl
+ vorbis? ( media-sound/vorbis-tools )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix for incompatible implicit declaration of built-in function ‘strlen’.
+ epatch "${FILESDIR}"/${P}-implicit-declaration.patch
+}
+
+src_compile() {
+ # Bug #69536
+ [[ $(tc-arch) == "x86" ]] && append-flags "-mno-sse"
+
+ strip-linguas be bg ca de en en_CA en_GB en_US es fi fr hu it ja nl pl_PL pt_BR ru zh_CN zh_HK zh_TW
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) || die "./configure failed"
+ emake || die "emake failed."
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS CREDITS ChangeLog README TODO
+}