summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-10 01:07:26 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-10 01:07:26 +0000
commitfc25549a89284be34c8a03f2c28c876caf4a1e70 (patch)
tree07963a3166655bd667b851f8afcb6ecb832e8c9d /media-sound/darkice
parentSign manifest (diff)
downloadgentoo-2-fc25549a89284be34c8a03f2c28c876caf4a1e70.tar.gz
gentoo-2-fc25549a89284be34c8a03f2c28c876caf4a1e70.tar.bz2
gentoo-2-fc25549a89284be34c8a03f2c28c876caf4a1e70.zip
Fix building with GLIBC 2.10 and GCC 4.4 wrt #277216, thanks to Diego E. 'Flameeyes' Pettenò.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/darkice')
-rw-r--r--media-sound/darkice/ChangeLog8
-rw-r--r--media-sound/darkice/darkice-0.18.1.ebuild51
-rw-r--r--media-sound/darkice/darkice-0.19.ebuild27
-rw-r--r--media-sound/darkice/files/darkice-0.19-gcc44.patch12
4 files changed, 34 insertions, 64 deletions
diff --git a/media-sound/darkice/ChangeLog b/media-sound/darkice/ChangeLog
index e34d52514f84..6fc804479b30 100644
--- a/media-sound/darkice/ChangeLog
+++ b/media-sound/darkice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/darkice
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/ChangeLog,v 1.54 2009/06/25 17:42:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/ChangeLog,v 1.55 2009/07/10 01:07:23 ssuominen Exp $
+
+ 10 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ -darkice-0.18.1.ebuild, darkice-0.19.ebuild,
+ +files/darkice-0.19-gcc44.patch:
+ Fix building with GLIBC 2.10 and GCC 4.4 wrt #277216, thanks to Diego E.
+ 'Flameeyes' Pettenò.
25 Jun 2009; Raúl Porcel <armin76@gentoo.org> darkice-0.19.ebuild:
sparc stable wrt #270783
diff --git a/media-sound/darkice/darkice-0.18.1.ebuild b/media-sound/darkice/darkice-0.18.1.ebuild
deleted file mode 100644
index a965ca30a3ea..000000000000
--- a/media-sound/darkice/darkice-0.18.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/darkice-0.18.1.ebuild,v 1.7 2008/03/27 10:45:18 drac Exp $
-
-inherit eutils
-
-DESCRIPTION="IceCast live streamer, delivering ogg and mp3 streams simultaneously to multiple hosts."
-HOMEPAGE="http://darkice.sourceforge.net"
-SRC_URI="http://${PN}.tyrell.hu/dist/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 hppa ppc sparc x86"
-IUSE="aac alsa encode jack twolame vorbis"
-
-RDEPEND="encode? ( media-sound/lame )
- vorbis? ( media-libs/libvorbis )
- aac? ( media-libs/faac )
- twolame? ( media-sound/twolame )
- alsa? ( media-libs/alsa-lib )
- jack? ( media-sound/jack-audio-connection-kit )
- !encode? ( !vorbis? ( !aac? ( !twolame? ( media-libs/libvorbis ) ) ) )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc43.patch
-}
-
-src_compile() {
- if ! use encode && ! use vorbis && ! use aac && ! use twolame; then
- ewarn "One of USE flags encode, vorbis, aac, or twolame is required."
- ewarn "Selecting vorbis for you."
- local myconf="--with-vorbis"
- fi
-
- econf $(use_with aac faac) \
- $(use_with alsa) \
- $(use_with encode lame) \
- $(use_with jack) \
- $(use_with twolame) \
- $(use_with vorbis) \
- ${myconf}
- emake || die "emake failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
- dodoc AUTHORS ChangeLog FAQ NEWS README TODO
-}
diff --git a/media-sound/darkice/darkice-0.19.ebuild b/media-sound/darkice/darkice-0.19.ebuild
index f87cc3c603b5..fd72c5d28834 100644
--- a/media-sound/darkice/darkice-0.19.ebuild
+++ b/media-sound/darkice/darkice-0.19.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/darkice-0.19.ebuild,v 1.6 2009/06/25 17:42:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/darkice/darkice-0.19.ebuild,v 1.7 2009/07/10 01:07:23 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="IceCast live streamer, delivering ogg and mp3 streams simultaneously to multiple hosts."
@@ -11,7 +12,7 @@ SRC_URI="http://${PN}.tyrell.hu/dist/${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 hppa ppc sparc x86"
-IUSE="aac alsa encode jack twolame vorbis"
+IUSE="aac alsa jack mp3 twolame vorbis"
RDEPEND="encode? ( media-sound/lame )
vorbis? ( media-libs/libvorbis )
@@ -19,33 +20,35 @@ RDEPEND="encode? ( media-sound/lame )
twolame? ( media-sound/twolame )
alsa? ( media-libs/alsa-lib )
jack? ( media-sound/jack-audio-connection-kit )
- !encode? ( !vorbis? ( !aac? ( !twolame? ( media-libs/libvorbis ) ) ) )"
+ !mp3? ( !vorbis? ( !aac? ( !twolame? ( media-sound/lame ) ) ) )"
DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PN}-0.18.1-gcc43.patch
+ epatch "${FILESDIR}"/${PN}-0.18.1-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
}
-src_compile() {
- if ! use encode && ! use vorbis && ! use aac && ! use twolame; then
- ewarn "One of USE flags encode, vorbis, aac, or twolame is required."
- ewarn "Selecting vorbis for you."
- local myconf="--with-vorbis"
+src_configure() {
+ local myconf
+
+ if ! use mp3 && ! use vorbis && ! use aac && ! use twolame; then
+ ewarn "One of USE flags mp3, vorbis, aac, or twolame is required."
+ ewarn "Selecting mp3 for you."
+ myconf="--with-lame"
fi
econf $(use_with aac faac) \
$(use_with alsa) \
- $(use_with encode lame) \
+ $(use_with mp3 lame) \
$(use_with jack) \
$(use_with twolame) \
$(use_with vorbis) \
${myconf}
- emake || die "emake failed."
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog FAQ NEWS README TODO
}
diff --git a/media-sound/darkice/files/darkice-0.19-gcc44.patch b/media-sound/darkice/files/darkice-0.19-gcc44.patch
new file mode 100644
index 000000000000..77388ccc2f0c
--- /dev/null
+++ b/media-sound/darkice/files/darkice-0.19-gcc44.patch
@@ -0,0 +1,12 @@
+diff -ur darkice-0.19.orig/src/Util.cpp darkice-0.19/src/Util.cpp
+--- darkice-0.19.orig/src/Util.cpp 2007-02-25 18:38:33.000000000 +0200
++++ darkice-0.19/src/Util.cpp 2009-07-10 04:08:37.000000000 +0300
+@@ -296,7 +296,7 @@
+ unsigned int size;
+ char * s;
+ char * strdate;
+- char * last;
++ const char * last;
+ time_t now;
+
+ if ( !str ) {