summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-20 19:42:26 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-20 19:42:26 +0000
commit6f7403d3522f192dbf3a549654c4d950558801c5 (patch)
treee2577ec398d70ef5b38d7461dbf24159ae253ae6 /media-sound/alsamixergui
parentFixed DEOEND misspelling (diff)
downloadgentoo-2-6f7403d3522f192dbf3a549654c4d950558801c5.tar.gz
gentoo-2-6f7403d3522f192dbf3a549654c4d950558801c5.tar.bz2
gentoo-2-6f7403d3522f192dbf3a549654c4d950558801c5.zip
After much headache. This is finally installable on gentoo. w00t!
The research into this solved some fltk+gcc3 issues as well. So anyway, yeah... on to committing!
Diffstat (limited to 'media-sound/alsamixergui')
-rw-r--r--media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild47
-rw-r--r--media-sound/alsamixergui/files/digest-alsamixergui-0.9.0.1.2-r11
-rw-r--r--media-sound/alsamixergui/files/fltk-1.1+gcc3.diff72
3 files changed, 120 insertions, 0 deletions
diff --git a/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild
new file mode 100644
index 000000000000..2486c8fb695f
--- /dev/null
+++ b/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsamixergui/alsamixergui-0.9.0.1.2-r1.ebuild,v 1.1 2002/09/20 19:42:26 raker Exp $
+
+NATIVE_VER=0.9.0rc1-2
+S=${WORKDIR}/${PN}-${NATIVE_VER}
+
+DESCRIPTION="AlsaMixerGui - a FLTK based amixer Frontend"
+HOMEPAGE="http://www.iua.upf.es/~mdeboer/projects/alsamixergui/"
+SRC_URI="ftp://www.iua.upf.es/pub/mdeboer/projects/alsamixergui/${PN}-${NATIVE_VER}.tar.gz"
+
+DEPEND=">=media-sound/alsa-driver-0.9.0_rc1
+ >=media-sound/alsa-lib-0.9.0_rc1
+ >=media-sound/alsa-utils-0.9.0_rc1
+ >=x11-libs/fltk-1.1.0_rc6"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/fltk-1.1+gcc3.diff || die "patch failed"
+
+}
+
+src_compile() {
+
+ export LDFLAGS="-L/usr/lib/fltk-1.1"
+ export CPPFLAGS="-I/usr/include/fltk-1.1"
+
+ econf || die "configure failed"
+
+ emake || die "make failed"
+
+}
+
+src_install () {
+
+ einstall || die
+
+ dodoc COPYING README AUTHORS ChangeLog
+
+}
diff --git a/media-sound/alsamixergui/files/digest-alsamixergui-0.9.0.1.2-r1 b/media-sound/alsamixergui/files/digest-alsamixergui-0.9.0.1.2-r1
new file mode 100644
index 000000000000..a47468b6e908
--- /dev/null
+++ b/media-sound/alsamixergui/files/digest-alsamixergui-0.9.0.1.2-r1
@@ -0,0 +1 @@
+MD5 24b74dda2cf77c313c6cba9b062c8feb alsamixergui-0.9.0rc1-2.tar.gz 70255
diff --git a/media-sound/alsamixergui/files/fltk-1.1+gcc3.diff b/media-sound/alsamixergui/files/fltk-1.1+gcc3.diff
new file mode 100644
index 000000000000..6b0463d66fcd
--- /dev/null
+++ b/media-sound/alsamixergui/files/fltk-1.1+gcc3.diff
@@ -0,0 +1,72 @@
+diff -urN alsamixergui-0.9.0rc1-2/Makefile.am alsamixergui-0.9.0rc1-2-modified/Makefile.am
+--- alsamixergui-0.9.0rc1-2/Makefile.am Fri Apr 26 05:16:23 2002
++++ alsamixergui-0.9.0rc1-2-modified/Makefile.am Fri Sep 20 13:59:06 2002
+@@ -1,2 +1,2 @@
+-SUBDIRS=src
++SUBDIRS = src
+ DISTCLEANFILES = configure Makefile.in missing install-sh mkinstalldirs COPYING INSTALL
+diff -urN alsamixergui-0.9.0rc1-2/configure alsamixergui-0.9.0rc1-2-modified/configure
+--- alsamixergui-0.9.0rc1-2/configure Fri May 3 04:40:38 2002
++++ alsamixergui-0.9.0rc1-2-modified/configure Fri Sep 20 14:08:14 2002
+@@ -1469,8 +1469,8 @@
+ fi
+
+
+-echo $ac_n "checking for numericsort in -lfltk""... $ac_c" 1>&6
+-echo "configure:1474: checking for numericsort in -lfltk" >&5
++echo $ac_n "checking for fl_numericsort in -lfltk""... $ac_c" 1>&6
++echo "configure:1474: checking for fl_numericsort in -lfltk" >&5
+ ac_lib_var=`echo fltk'_'numericsort | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+@@ -1483,10 +1483,10 @@
+ /* Override any gcc2 internal prototype to avoid an error. */
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char numericsort();
++char fl_numericsort();
+
+ int main() {
+-numericsort()
++fl_numericsort()
+ ; return 0; }
+ EOF
+ if { (eval echo configure:1493: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+diff -urN alsamixergui-0.9.0rc1-2/configure.in alsamixergui-0.9.0rc1-2-modified/configure.in
+--- alsamixergui-0.9.0rc1-2/configure.in Fri May 3 04:40:21 2002
++++ alsamixergui-0.9.0rc1-2-modified/configure.in Fri Sep 20 13:42:05 2002
+@@ -11,7 +11,7 @@
+ AC_PROG_LN_S
+
+ dnl Checks for libraries.
+-AC_CHECK_LIB(fltk,numericsort,,AC_MSG_ERROR("missing fltk"))
++AC_CHECK_LIB(fltk,fl_numericsort,,AC_MSG_ERROR("missing fltk"))
+ AM_PATH_ALSA(0.9.0)
+
+ dnl Checks for header files.
+diff -urN alsamixergui-0.9.0rc1-2/src/Fl_AM.cxx alsamixergui-0.9.0rc1-2-modified/src/Fl_AM.cxx
+--- alsamixergui-0.9.0rc1-2/src/Fl_AM.cxx Fri May 3 04:37:27 2002
++++ alsamixergui-0.9.0rc1-2-modified/src/Fl_AM.cxx Fri Sep 20 13:41:59 2002
+@@ -215,7 +215,7 @@
+ Fl::add_timeout(0.05,gui_idle_cb,0);
+
+ #if FL_MAJOR_VERSION == 1 && FL_MINOR_VERSION >= 1
+- Fl::visible_focus(0);
++// Fl::visible_focus(0);
+ #endif
+
+ Fl::run();
+diff -urN alsamixergui-0.9.0rc1-2/src/Fl_Pixmap_Button.H alsamixergui-0.9.0rc1-2-modified/src/Fl_Pixmap_Button.H
+--- alsamixergui-0.9.0rc1-2/src/Fl_Pixmap_Button.H Fri Apr 26 03:23:39 2002
++++ alsamixergui-0.9.0rc1-2-modified/src/Fl_Pixmap_Button.H Fri Sep 20 13:42:07 2002
+@@ -48,8 +48,8 @@
+ #endif
+
+ if (pw<0) {
+-#if FL_MAJOR_VERSION == 1 && FL_MINOR_VERSION == 0
+- fl_measure_pixmap(p->data,pw,ph);
++#if FL_MAJOR_VERSION == 1 && FL_MINOR_VERSION >= 0
++ fl_measure_pixmap(p->data(),pw,ph);
+ #else
+ fl_measure_pixmap(p->data(),pw,ph);
+ #endif