summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-12-29 06:37:59 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-12-29 06:37:59 +0000
commitda6a6480c33fc8af3a4050390cefccfda9f574e3 (patch)
treea28c40bb8f9a0d95335262f334f3408a3f474269 /media-sound/alsa-utils
parentupdated depends for bug 203587 (diff)
downloadgentoo-2-da6a6480c33fc8af3a4050390cefccfda9f574e3.tar.gz
gentoo-2-da6a6480c33fc8af3a4050390cefccfda9f574e3.tar.bz2
gentoo-2-da6a6480c33fc8af3a4050390cefccfda9f574e3.zip
Add variables to block the automatic module load/unload, to help out cases where they do weird things, like my G5 with snd-aoa.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog7
-rw-r--r--media-sound/alsa-utils/files/alsasound.confd12
-rw-r--r--media-sound/alsa-utils/files/alsasound.initd8
3 files changed, 22 insertions, 5 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index a0959f105e3b..d6705eb0a13e 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.221 2007/10/24 19:52:41 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.222 2007/12/29 06:37:59 robbat2 Exp $
+
+ 29 Dec 2007; Robin H. Johnson <robbat2@gentoo.org> files/alsasound.confd,
+ files/alsasound.initd:
+ Add variables to block the automatic module load/unload, to help out cases
+ where they do weird things, like my G5 with snd-aoa.
24 Oct 2007; Christian Heim <phreak@gentoo.org> -alsa-utils-1.0.13.ebuild,
-alsa-utils-1.0.14_rc1.ebuild, -alsa-utils-1.0.15_rc1.ebuild:
diff --git a/media-sound/alsa-utils/files/alsasound.confd b/media-sound/alsa-utils/files/alsasound.confd
index 6e82cdd32e95..0d63dcfe647b 100644
--- a/media-sound/alsa-utils/files/alsasound.confd
+++ b/media-sound/alsa-utils/files/alsasound.confd
@@ -20,3 +20,15 @@ RESTORE_ON_START="yes"
# yes - Save state
SAVE_ON_STOP="yes"
+
+# LOAD_ON_START:
+# Do you want to load sound modules when alsasound starts?
+# no - Do not load modules
+# yes - Load modules
+LOAD_ON_START="yes"
+
+# UNLOAD_ON_STOP:
+# Do you want to unload sound modules when alsasound stops?
+# no - Do not unload modules
+# yes - Unload modules
+UNLOAD_ON_STOP="yes"
diff --git a/media-sound/alsa-utils/files/alsasound.initd b/media-sound/alsa-utils/files/alsasound.initd
index 4c8b8129d8b4..ac0a169a5cda 100644
--- a/media-sound/alsa-utils/files/alsasound.initd
+++ b/media-sound/alsa-utils/files/alsasound.initd
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsasound.initd,v 1.5 2007/03/19 21:32:12 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsasound.initd,v 1.6 2007/12/29 06:37:59 robbat2 Exp $
# Copyright 2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
@@ -187,7 +187,7 @@ save() {
}
start() {
- if [ -f /proc/modules ] ; then
+ if [ -f /proc/modules ] && [ "${LOAD_ON_START}" = "yes" ]; then
ebegin "Loading ALSA modules"
eindent
load_modules
@@ -217,8 +217,8 @@ stop() {
ebegin "Killing processes using ALSA"
terminate
eend 0
-
- if [ -f /proc/modules ]; then
+
+ if [ -f /proc/modules ] && [ "${UNLOAD_ON_STOP}" = "yes" ]; then
local ver="24"
rmmod --version | grep -q module-init-tools && ver="26"