summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-24 16:03:07 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-24 16:03:07 +0000
commit90ad1c89fcfa988c67d8b1d615a1b30f36989af7 (patch)
tree5d6dff6c2509cd3818389f89d4eaef10f693e681 /media-sound/alsa-utils/alsa-utils-0.9.8.ebuild
parentVersion bumped. (diff)
downloadgentoo-2-90ad1c89fcfa988c67d8b1d615a1b30f36989af7.tar.gz
gentoo-2-90ad1c89fcfa988c67d8b1d615a1b30f36989af7.tar.bz2
gentoo-2-90ad1c89fcfa988c67d8b1d615a1b30f36989af7.zip
Version bumped.
Diffstat (limited to 'media-sound/alsa-utils/alsa-utils-0.9.8.ebuild')
-rw-r--r--media-sound/alsa-utils/alsa-utils-0.9.8.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-sound/alsa-utils/alsa-utils-0.9.8.ebuild b/media-sound/alsa-utils/alsa-utils-0.9.8.ebuild
new file mode 100644
index 000000000000..0aefd5d2965b
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-0.9.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-0.9.8.ebuild,v 1.1 2003/10/24 16:03:02 mholzer Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+DEPEND=">=sys-libs/ncurses-5.1
+ >=media-libs/alsa-lib-0.9.8"
+
+SLOT="0.9"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+SRC_URI="mirror://alsaproject/utils/${P}.tar.bz2"
+RESTRICT="nomirror"
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ econf || die "./configure failed"
+ emake || die "Parallel Make Failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="COPYING ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ make DESTDIR=${D} install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ dodir /etc/init.d
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf-rc alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst() {
+ echo
+ einfo "The alsasound initscript is now provided by alsa-utils"
+ einfo "instead of alsa-driver for compatibility with kernel-sources"
+ einfo "which provide ALSA internally."
+ echo
+ einfo "To take advantage of this, and automate the process of"
+ einfo "loading and unloading the ALSA sound drivers as well as"
+ einfo "storing and restoring sound-card mixer levels you should"
+ einfo "add alsasound to the boot runlevel. You can do this as"
+ einfo "root like so:"
+ einfo " # rc-update add alsasound boot"
+ echo
+ einfo "You will also need to edit the file /etc/modules.d/alsa"
+ einfo "and run update-modules. You can do this like so:"
+ einfo " # nano -w /etc/modules.d/alsa && update-modules"
+ echo
+ ewarn "Pausing for 20 seconds to give you time to read..."
+ sleep 20
+}