summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2013-03-03 18:42:51 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2013-03-03 18:42:51 +0000
commitf2a7153bba061a4eb327ae4d89fc252f387a9790 (patch)
treeb8f5592d0b3fe831984d810ee03fb50d49bf2330 /media-radio
parentVersion bump for security bug 460168. (diff)
downloadgentoo-2-f2a7153bba061a4eb327ae4d89fc252f387a9790.tar.gz
gentoo-2-f2a7153bba061a4eb327ae4d89fc252f387a9790.tar.bz2
gentoo-2-f2a7153bba061a4eb327ae4d89fc252f387a9790.zip
Improve build logic. Thanks for help Michal
(Portage version: 2.1.11.53/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/wspr/ChangeLog5
-rw-r--r--media-radio/wspr/wspr-2.00-r1.ebuild58
2 files changed, 30 insertions, 33 deletions
diff --git a/media-radio/wspr/ChangeLog b/media-radio/wspr/ChangeLog
index 596d04d3d869..529c54a43097 100644
--- a/media-radio/wspr/ChangeLog
+++ b/media-radio/wspr/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-radio/wspr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/ChangeLog,v 1.8 2013/03/03 16:59:10 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/ChangeLog,v 1.9 2013/03/03 18:42:51 tomjbe Exp $
+
+ 03 Mar 2013; Thomas Beierlein <tomjbe@gentoo.org> wspr-2.00-r1.ebuild:
+ Improve build logic. Thanks for help Michal
03 Mar 2013; Thomas Beierlein <tomjbe@gentoo.org> wspr-2.00-r1.ebuild:
Fix lookup for portaudio (bug #459024). Thanks for reporting Michal
diff --git a/media-radio/wspr/wspr-2.00-r1.ebuild b/media-radio/wspr/wspr-2.00-r1.ebuild
index bb20f05cc373..98ec86e26d7b 100644
--- a/media-radio/wspr/wspr-2.00-r1.ebuild
+++ b/media-radio/wspr/wspr-2.00-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/wspr-2.00-r1.ebuild,v 1.2 2013/03/03 16:59:10 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/wspr-2.00-r1.ebuild,v 1.3 2013/03/03 18:42:51 tomjbe Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -31,16 +31,8 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
-PATCHES=(
- "${FILESDIR}"/${P}-libdir.patch
- "${FILESDIR}"/${P}-verbose.patch
- "${FILESDIR}"/${P}-script.patch
- )
-
DOCS=( BUGS WSPR_Announcement.TXT WSPR_Instructions.TXT WSPR_Quick_Start.TXT )
-DISTUTILS_IN_SOURCE_BUILD=1
-
pkg_setup() {
fortran-2_pkg_setup
}
@@ -52,48 +44,50 @@ get_fcomp() {
esac
}
-python_prepare() {
- sed -i -e "s#/usr/local/lib#/usr/$(get_libdir)#" configure.ac || die
- eautoreconf
-}
-
-src_prepare() {
+python_prepare_all() {
tc-export FC
get_fcomp
export FC="${FCOMP}"
+ local PATCHES=(
+ "${FILESDIR}"/${P}-libdir.patch
+ "${FILESDIR}"/${P}-verbose.patch
+ "${FILESDIR}"/${P}-script.patch
+ )
+
distutils-r1_python_prepare_all
- python_foreach_impl run_in_build_dir python_prepare
+
+ sed -i -e "s#/usr/local/lib#/usr/$(get_libdir)#" configure.ac || die
+ sed -i -e '/makedirs/d' setup.py || die
+ eautoreconf
}
-python_configure() {
- # configure the built of the fortran module
+# Note: very hacky build system.
+# autoconf which doesn't really need Python
+# then custom Makefile which compiles the Python module with f2py
+# and finally hacked setup.py which relies on w.so created by make
+
+src_configure() {
+ # configure the build of the fortran module
econf --with-portaudio-lib-dir=/usr/$(get_libdir)
+
+ # then fork the sources
+ python_copy_sources
+ DISTUTILS_IN_SOURCE_BUILD=1
}
python_compile() {
# -shared is neded by f2py but cannot be set earlier as configure does
# not like it
+ local LDFLAGS=${LDFLAGS}
append-ldflags -shared
emake
}
-src_install() {
- doit() {
- rm -rf build || die
- distutils-r1_python_install
- }
-
- python_foreach_impl run_in_build_dir doit
+python_install_all() {
distutils-r1_python_install_all
dobin wspr
insinto /usr/share/${PN}
doins hamlib_rig_numbers
-}
-
-run_in_build_dir() {
- pushd "${BUILD_DIR}" > /dev/null || die
- "$@"
- popd > /dev/null
-}
+} \ No newline at end of file