summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2010-10-30 07:32:33 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2010-10-30 07:32:33 +0000
commitf08132a29915e0aad521bf022db6a74dac012433 (patch)
tree6e048e3044505c14a0a23c404e758227af05b7c2 /media-radio
parentFix encoding in ChangeLog (diff)
downloadgentoo-2-f08132a29915e0aad521bf022db6a74dac012433.tar.gz
gentoo-2-f08132a29915e0aad521bf022db6a74dac012433.tar.bz2
gentoo-2-f08132a29915e0aad521bf022db6a74dac012433.zip
Minor version bump. Fixes some buffer overruns.
(Portage version: 2.1.9.23/cvs/Linux x86_64)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/xlog/ChangeLog7
-rw-r--r--media-radio/xlog/xlog-2.0.4.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/media-radio/xlog/ChangeLog b/media-radio/xlog/ChangeLog
index 43215e0a3fef..eb33f845bd07 100644
--- a/media-radio/xlog/ChangeLog
+++ b/media-radio/xlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/xlog
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/ChangeLog,v 1.16 2010/10/24 10:51:30 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/ChangeLog,v 1.17 2010/10/30 07:32:33 tomjbe Exp $
+
+*xlog-2.0.4 (30 Oct 2010)
+
+ 30 Oct 2010; Thomas Beierlein <tomjbe@gentoo.org> +xlog-2.0.4.ebuild:
+ Minor version bump. Fixes some buffer overruns.
*xlog-2.0.3-r1 (24 Oct 2010)
diff --git a/media-radio/xlog/xlog-2.0.4.ebuild b/media-radio/xlog/xlog-2.0.4.ebuild
new file mode 100644
index 000000000000..ee9ff97af921
--- /dev/null
+++ b/media-radio/xlog/xlog-2.0.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/xlog/xlog-2.0.4.ebuild,v 1.1 2010/10/30 07:32:33 tomjbe Exp $
+
+EAPI=2
+
+inherit autotools eutils fdo-mime
+
+DESCRIPTION="An amateur radio logging program"
+HOMEPAGE="http://www.nongnu.org/xlog"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/hamlib
+ =dev-libs/glib-2*
+ >=x11-libs/gtk+-2.12"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Let portage handle updating mime/desktop databases,
+ epatch "${FILESDIR}/${PN}-1.9-desktop-update.patch"
+ # and patch wrong ADIF export
+ epatch "${FILESDIR}"/${PN}-2.0.1-adif.patch \
+ "${FILESDIR}"/${PN}-2.0.2-qsl.patch
+ eautoreconf
+}
+
+src_configure() {
+ # mime-update causes file collisions if enabled
+ econf --disable-mime-update --disable-desktop-update \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS data/doc/THANKS NEWS README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}