summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-04-07 19:51:50 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-04-07 19:51:50 +0000
commit65b8ced00c535447f6d0c786ab78e2376ad73e57 (patch)
tree35b3ec8fe9d779e876e02eb5569be020fc8a4965 /media-plugins/vdr-live/vdr-live-0.1.0.20080407.ebuild
parentstable for x86 (diff)
downloadgentoo-2-65b8ced00c535447f6d0c786ab78e2376ad73e57.tar.gz
gentoo-2-65b8ced00c535447f6d0c786ab78e2376ad73e57.tar.bz2
gentoo-2-65b8ced00c535447f6d0c786ab78e2376ad73e57.zip
Added new snapshot.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'media-plugins/vdr-live/vdr-live-0.1.0.20080407.ebuild')
-rw-r--r--media-plugins/vdr-live/vdr-live-0.1.0.20080407.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-plugins/vdr-live/vdr-live-0.1.0.20080407.ebuild b/media-plugins/vdr-live/vdr-live-0.1.0.20080407.ebuild
new file mode 100644
index 000000000000..7c35054b0511
--- /dev/null
+++ b/media-plugins/vdr-live/vdr-live-0.1.0.20080407.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.1.0.20080407.ebuild,v 1.1 2008/04/07 19:51:50 zzam Exp $
+
+inherit vdr-plugin versionator
+
+MY_PV=$(get_version_component_range 4)
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="VDR Plugin: Web Access To Settings"
+HOMEPAGE="http://live.vdr-developer.org"
+#SRC_URI="http://live.vdr-developer.org/downloads/${MY_PP}.tar.gz"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-video/vdr
+ >=dev-libs/boost-1.33.0
+ dev-libs/tntnet
+ >=dev-libs/cxxtools-1.4.3"
+
+S="${WORKDIR}/${VDRPLUGIN}"
+
+src_install() {
+ vdr-plugin_src_install
+
+ cd "${S}/live"
+ insinto /etc/vdr/plugins/live
+ doins -r *
+
+ chown vdr:vdr -R "${D}"/etc/vdr/plugins/live
+}
+
+pkg_postinst() {
+ vdr-plugin_pkg_postinst
+
+ elog "To be able to use all functions of vdr-live"
+ elog "you should emerge and enable vdr-epgsearch"
+ elog
+ elog "\temerge vdr-epgsearch"
+ elog "\teselect vdr-plugin enable epgsearch"
+}