summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2009-10-23 14:28:26 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2009-10-23 14:28:26 +0000
commit5db672ca898295705f637388b00cc484f8156d5f (patch)
tree34819cc523e91905a5587a17a1d50235fe5ebdaf /media-plugins/vdr-graphtft/files
parentStable for HPPA (bug #287239). (diff)
downloadgentoo-2-5db672ca898295705f637388b00cc484f8156d5f.tar.gz
gentoo-2-5db672ca898295705f637388b00cc484f8156d5f.tar.bz2
gentoo-2-5db672ca898295705f637388b00cc484f8156d5f.zip
fixed compile for graphtft-fe
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-plugins/vdr-graphtft/files')
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff22
-rw-r--r--media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff15
2 files changed, 36 insertions, 1 deletions
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff
index 90bc2405be3c..da23096138fe 100644
--- a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_gcc-4.4.x.diff
@@ -48,3 +48,25 @@ diff -urNad vdr-plugin-graphtft-0.3.2~rc2+svn20090728.2153/theme.c vdr-plugin-gr
{
tell(0, "Parsing of [%s] failed, missing bracket '}'", expression);
return fail;
+diff -Naur graphtft-24.orig/graphtft-fe/common.cc graphtft-24/graphtft-fe/common.cc
+--- graphtft-24.orig/graphtft-fe/common.cc 2009-10-23 15:10:20.000000000 +0200
++++ graphtft-24/graphtft-fe/common.cc 2009-10-23 15:11:11.000000000 +0200
+@@ -11,6 +11,7 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #include <graphtft.hpp>
+
+diff -Naur graphtft-24.orig/graphtft-fe/graphtft.hpp graphtft-24/graphtft-fe/graphtft.hpp
+--- graphtft-24.orig/graphtft-fe/graphtft.hpp 2009-10-23 15:10:20.000000000 +0200
++++ graphtft-24/graphtft-fe/graphtft.hpp 2009-10-23 15:11:36.000000000 +0200
+@@ -16,6 +16,7 @@
+ #include <X11/Xlib.h>
+ #include <Imlib2.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #define __FRONTEND
+ #include <../common.h>
diff --git a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff
index 5e9c3e885f30..f638be630069 100644
--- a/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff
+++ b/media-plugins/vdr-graphtft/files/vdr-graphtft-0.3.2.24_makefile.diff
@@ -1,4 +1,5 @@
-Joerg Bornkessel <hd_brummy@g.o> 22 Aug 2009
+Joerg Bornkessel <hd_brummy@g.o> 22 Okt 2009
+Matthias Schwarzott <zzam@g.o> 23 Okt 2009
diff -Naur graphtft-24.orig/Makefile graphtft-24/Makefile
--- graphtft-24.orig/Makefile 2009-10-21 21:53:56.000000000 +0200
+++ graphtft-24/Makefile 2009-10-21 21:57:24.000000000 +0200
@@ -52,3 +53,15 @@ diff -Naur graphtft-24.orig/graphtft-fe/Makefile graphtft-24/graphtft-fe/Makefil
AR = ar
TARGET = graphtft-fe
+diff -Naur graphtft-24.orig/graphtft-fe/Makefile graphtft-24/graphtft-fe/Makefile
+--- graphtft-24.orig/graphtft-fe/Makefile 2009-10-23 16:20:43.000000000 +0200
++++ graphtft-24/graphtft-fe/Makefile 2009-10-23 16:21:20.000000000 +0200
+@@ -17,7 +17,7 @@
+
+ all:
+ echo Build graphTFT Frontend
+- @(make $(TARGET))
++ @$(MAKE) $(TARGET)
+
+
+ $(TARGET): $(OBJECTS)