summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank van de Pol <fvdpol@gentoo.org>2004-11-21 19:10:42 +0000
committerFrank van de Pol <fvdpol@gentoo.org>2004-11-21 19:10:42 +0000
commitb7e40eabd9d2c788138a23ca74ec15868719c9a2 (patch)
treeae4964877ec469627a7b19d806f4e69ae079de03 /media-plugins/swh-plugins
parentset DEPEND to || ( app-arch/rpm2targz app-arch/rpm ) (Manifest recommit) (diff)
downloadgentoo-2-b7e40eabd9d2c788138a23ca74ec15868719c9a2.tar.gz
gentoo-2-b7e40eabd9d2c788138a23ca74ec15868719c9a2.tar.bz2
gentoo-2-b7e40eabd9d2c788138a23ca74ec15868719c9a2.zip
Version bump to 0.4.11 + amd64 PIC fix.
Diffstat (limited to 'media-plugins/swh-plugins')
-rw-r--r--media-plugins/swh-plugins/ChangeLog5
-rw-r--r--media-plugins/swh-plugins/files/digest-swh-plugins-0.4.111
-rw-r--r--media-plugins/swh-plugins/swh-plugins-0.4.11.ebuild42
3 files changed, 47 insertions, 1 deletions
diff --git a/media-plugins/swh-plugins/ChangeLog b/media-plugins/swh-plugins/ChangeLog
index cd602370dd91..3caaf6f79dde 100644
--- a/media-plugins/swh-plugins/ChangeLog
+++ b/media-plugins/swh-plugins/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-plugins/swh-plugins
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/ChangeLog,v 1.23 2004/09/28 18:32:05 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/ChangeLog,v 1.24 2004/11/21 19:10:42 fvdpol Exp $
+
+ 21 Nov 2004; Frank van de Pol <fvdpol@gentoo.org> :
+ Version bump to 0.4.11 + amd64 PIC fix.
28 Sep 2004; Jeremy Huddleston <eradicator@gentoo.org>
swh-plugins-0.4.7.ebuild:
diff --git a/media-plugins/swh-plugins/files/digest-swh-plugins-0.4.11 b/media-plugins/swh-plugins/files/digest-swh-plugins-0.4.11
new file mode 100644
index 000000000000..ecd99c0c4b79
--- /dev/null
+++ b/media-plugins/swh-plugins/files/digest-swh-plugins-0.4.11
@@ -0,0 +1 @@
+MD5 eaee4b55be1d370014d5ee728bbf1c52 swh-plugins-0.4.11.tar.gz 894727
diff --git a/media-plugins/swh-plugins/swh-plugins-0.4.11.ebuild b/media-plugins/swh-plugins/swh-plugins-0.4.11.ebuild
new file mode 100644
index 000000000000..60fb697034ef
--- /dev/null
+++ b/media-plugins/swh-plugins/swh-plugins-0.4.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/swh-plugins-0.4.11.ebuild,v 1.1 2004/11/21 19:10:42 fvdpol Exp $
+
+inherit flag-o-matic eutils
+
+IUSE=""
+DESCRIPTION="Large collection of LADSPA audio plugins/effects"
+HOMEPAGE="http://plugin.org.uk"
+SRC_URI="http://plugin.org.uk/releases/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+DEPEND="media-libs/ladspa-sdk
+ dev-libs/fftw
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A} || die
+
+ use amd64 && append-flags -fPIC
+ use ppc && append-flags -fPIC
+
+ cd ${S}
+ sed -i '/MACHINE=/s/.*/MACHINE=""/' configure
+}
+
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING README TODO || die
+}
+
+pkg_postinst() {
+ ewarn "WARNING: You have to be careful when using the "
+ ewarn "swh plugins. Be sure to lower your sound volume "
+ ewarn "and then play around a bit with the plugins so "
+ ewarn "you get a feeling for it. Otherwise your speakers"
+ ewarn "won't like that. "
+}