summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-11-07 21:46:15 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-11-07 21:46:15 +0000
commitad21167a033a0aafef09f0699ce7338c447eed63 (patch)
treec07c2573d31a69c1b003b913a79092f45f5f7f31 /media-plugins/swh-plugins
parentnew package (diff)
downloadgentoo-2-ad21167a033a0aafef09f0699ce7338c447eed63.tar.gz
gentoo-2-ad21167a033a0aafef09f0699ce7338c447eed63.tar.bz2
gentoo-2-ad21167a033a0aafef09f0699ce7338c447eed63.zip
new package
Diffstat (limited to 'media-plugins/swh-plugins')
-rw-r--r--media-plugins/swh-plugins/swh-plugins-0.2.8.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/swh-plugins/swh-plugins-0.2.8.ebuild b/media-plugins/swh-plugins/swh-plugins-0.2.8.ebuild
new file mode 100644
index 000000000000..d80b801e63cc
--- /dev/null
+++ b/media-plugins/swh-plugins/swh-plugins-0.2.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/swh-plugins-0.2.8.ebuild,v 1.1 2002/11/07 21:46:15 seemant Exp $
+
+IUSE=""
+DESCRIPTION="Cool GPL'd audio plugins/effects for use with ALSA and LADSPA"
+HOMEPAGE="http://plugin.org.uk"
+SRC_URI="http://plugin.org.uk/releases/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="media-sound/alsa-driver
+ dev-libs/fftw"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PN}-quickfixes.patch || die
+}
+
+src_compile() {
+
+ autoconf
+ econf
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING README TODO || die
+}
+
+pkg_postinst() {
+ ewarn "WARNING: You have to be careful when using the "
+ ewarn "swh plugins. Be sure to lower your sound volume "
+ ewarn "and then play around a bit with the plugins so "
+ ewarn "you get a feeling for it. Otherwise your speakers"
+ ewarn "won't like that. "
+}