summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorben Hohn <torbenh@gentoo.org>2004-01-19 08:19:03 +0000
committerTorben Hohn <torbenh@gentoo.org>2004-01-19 08:19:03 +0000
commitc3962589dd1d888af8afbbcb1057f0d941859229 (patch)
treeda31e5ae9206507fcebe0740f2f55df2e6500967 /media-plugins/swh-plugins/swh-plugins-0.4.3.ebuild
parentversion bumped to 0.4.3 (diff)
downloadgentoo-2-c3962589dd1d888af8afbbcb1057f0d941859229.tar.gz
gentoo-2-c3962589dd1d888af8afbbcb1057f0d941859229.tar.bz2
gentoo-2-c3962589dd1d888af8afbbcb1057f0d941859229.zip
version bumped to 0.4.3
Diffstat (limited to 'media-plugins/swh-plugins/swh-plugins-0.4.3.ebuild')
-rw-r--r--media-plugins/swh-plugins/swh-plugins-0.4.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/swh-plugins/swh-plugins-0.4.3.ebuild b/media-plugins/swh-plugins/swh-plugins-0.4.3.ebuild
new file mode 100644
index 000000000000..250cbf877af4
--- /dev/null
+++ b/media-plugins/swh-plugins/swh-plugins-0.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/swh-plugins/swh-plugins-0.4.3.ebuild,v 1.1 2004/01/19 08:18:51 torbenh Exp $
+
+IUSE="alsa"
+DESCRIPTION="Cool GPL'd audio plugins/effects for use with ALSA and LADSPA"
+HOMEPAGE="http://plugin.org.uk"
+SRC_URI="http://plugin.org.uk/releases/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="media-libs/ladspa-sdk
+ dev-libs/fftw
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A} || die
+
+ cd ${S}
+ sed -i '/MACHINE=/s/.*/MACHINE=""/' configure
+}
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING README TODO || die
+}
+
+pkg_postinst() {
+ ewarn "WARNING: You have to be careful when using the "
+ ewarn "swh plugins. Be sure to lower your sound volume "
+ ewarn "and then play around a bit with the plugins so "
+ ewarn "you get a feeling for it. Otherwise your speakers"
+ ewarn "won't like that. "
+}