summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:55:51 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-12-11 21:55:51 +0000
commitb68987e9d0009c54474b882634e408881adae6a3 (patch)
tree285e8b16e509f6466697c03f98741d3f3d03013c /media-plugins/mythweather
parentversion bumps (diff)
downloadgentoo-2-b68987e9d0009c54474b882634e408881adae6a3.tar.gz
gentoo-2-b68987e9d0009c54474b882634e408881adae6a3.tar.bz2
gentoo-2-b68987e9d0009c54474b882634e408881adae6a3.zip
version bumps
Diffstat (limited to 'media-plugins/mythweather')
-rw-r--r--media-plugins/mythweather/ChangeLog7
-rw-r--r--media-plugins/mythweather/Manifest4
-rw-r--r--media-plugins/mythweather/files/digest-mythweather-0.131
-rw-r--r--media-plugins/mythweather/mythweather-0.13.ebuild39
4 files changed, 48 insertions, 3 deletions
diff --git a/media-plugins/mythweather/ChangeLog b/media-plugins/mythweather/ChangeLog
index c03fa6c27aaf..4f0631b38951 100644
--- a/media-plugins/mythweather/ChangeLog
+++ b/media-plugins/mythweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythweather
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.8 2003/12/08 17:16:07 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.9 2003/12/11 21:55:47 aliz Exp $
+
+*mythweather-0.13 (11 Dec 2003)
+
+ 11 Dec 2003; Daniel Ahlberg <aliz@gentoo.org> mythweather-0.13.ebuild:
+ Version bump.
08 Dec 2003; <max@gentoo.org> mythweather-0.10.ebuild:
Remove stale version.
diff --git a/media-plugins/mythweather/Manifest b/media-plugins/mythweather/Manifest
index 8bec5844fe3e..871c35594c84 100644
--- a/media-plugins/mythweather/Manifest
+++ b/media-plugins/mythweather/Manifest
@@ -1,7 +1,7 @@
MD5 860c410d8ecf89fca2f87188220346b7 mythweather-0.12.ebuild 979
MD5 103f2dc2a77568b205f86d9f8a21e4a8 mythweather-0.11.ebuild 972
-MD5 860c410d8ecf89fca2f87188220346b7 mythweather-0.13.ebuild 979
-MD5 312125cee5e9f3162959a716991ed9d3 ChangeLog 1761
+MD5 2010eadcf11c848c70b6a258d2aae42b mythweather-0.13.ebuild 980
+MD5 27c2a1028161b6cccca62e83ff60ee5a ChangeLog 1885
MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 6a31e4f0a87c61e3e7f0eb55dca2f03b files/digest-mythweather-0.11 69
MD5 916ba5d7844b0abae782627b8d1a21fe files/digest-mythweather-0.12 69
diff --git a/media-plugins/mythweather/files/digest-mythweather-0.13 b/media-plugins/mythweather/files/digest-mythweather-0.13
new file mode 100644
index 000000000000..7d623e427962
--- /dev/null
+++ b/media-plugins/mythweather/files/digest-mythweather-0.13
@@ -0,0 +1 @@
+MD5 6e24255b7b2634a9343eacf7f75b4344 mythweather-0.13.tar.bz2 829213
diff --git a/media-plugins/mythweather/mythweather-0.13.ebuild b/media-plugins/mythweather/mythweather-0.13.ebuild
new file mode 100644
index 000000000000..247c95b4bcd7
--- /dev/null
+++ b/media-plugins/mythweather/mythweather-0.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.13.ebuild,v 1.1 2003/12/11 21:55:47 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Weather forcast module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ dodoc AUTHORS COPYING README
+}