summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-02-03 13:51:53 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-02-03 13:51:53 +0000
commite4f208dd887e639fdac3f8a599c7c06cac41dde1 (patch)
tree59db30fcd642a5476b02fdfb3a3ff5fd7dc18f2f /media-plugins/mythgame
parentIntroduced CVS snapshot (diff)
downloadgentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.tar.gz
gentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.tar.bz2
gentoo-2-e4f208dd887e639fdac3f8a599c7c06cac41dde1.zip
Version bump
Diffstat (limited to 'media-plugins/mythgame')
-rw-r--r--media-plugins/mythgame/ChangeLog7
-rw-r--r--media-plugins/mythgame/Manifest2
-rw-r--r--media-plugins/mythgame/files/digest-mythgame-0.141
-rw-r--r--media-plugins/mythgame/mythgame-0.14.ebuild66
4 files changed, 75 insertions, 1 deletions
diff --git a/media-plugins/mythgame/ChangeLog b/media-plugins/mythgame/ChangeLog
index ae9f3d80ae32..b39fa9048929 100644
--- a/media-plugins/mythgame/ChangeLog
+++ b/media-plugins/mythgame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythgame
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.10 2004/01/15 18:04:36 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.11 2004/02/03 13:51:53 aliz Exp $
+
+*mythgame-0.14 (03 Feb 2004)
+
+ 03 Feb 2004; Daniel Ahlberg <aliz@gentoo.org> mythgame-0.14.ebuild:
+ Version bump
15 Jan 2004; Max Kalika <max@gentoo.org> mythgame-0.13.ebuild:
Bump to stable x86.
diff --git a/media-plugins/mythgame/Manifest b/media-plugins/mythgame/Manifest
index 53e6e7f50116..d470c7b54149 100644
--- a/media-plugins/mythgame/Manifest
+++ b/media-plugins/mythgame/Manifest
@@ -1,4 +1,5 @@
MD5 460b6a4bd044f61e7a12918894b083a8 mythgame-0.12.ebuild 1979
+MD5 184c70d394443de35b1cdd1ab470fbb1 mythgame-0.14.ebuild 1980
MD5 48e8b79e645e8f6bd87b5a82f2af177d mythgame-0.11.ebuild 1976
MD5 1bdcecbda5a923f58fb1b98217bda045 mythgame-0.13.ebuild 1979
MD5 d5aba18183f7797f30e1d021d903b60a ChangeLog 2069
@@ -6,3 +7,4 @@ MD5 20e2255501865de5b568424821abf69d metadata.xml 161
MD5 2bd60d4f779ab52e53d15145940b8946 files/digest-mythgame-0.11 65
MD5 ace6a7f7f30d271f0c3e7bb1ea4ea89b files/digest-mythgame-0.12 65
MD5 ba98a6a8ff627a1e603a490d0c21a131 files/digest-mythgame-0.13 65
+MD5 b2fb16ec79b3ec5d217bc4d12d5701a9 files/digest-mythgame-0.14 65
diff --git a/media-plugins/mythgame/files/digest-mythgame-0.14 b/media-plugins/mythgame/files/digest-mythgame-0.14
new file mode 100644
index 000000000000..bf9c2bc8f9b8
--- /dev/null
+++ b/media-plugins/mythgame/files/digest-mythgame-0.14
@@ -0,0 +1 @@
+MD5 9b3428011cf7bf61aa4868c394e75cfa mythgame-0.14.tar.bz2 65133
diff --git a/media-plugins/mythgame/mythgame-0.14.ebuild b/media-plugins/mythgame/mythgame-0.14.ebuild
new file mode 100644
index 000000000000..3df83bb5a391
--- /dev/null
+++ b/media-plugins/mythgame/mythgame-0.14.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.14.ebuild,v 1.1 2004/02/03 13:51:53 aliz Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Game emulator module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/zlib
+ >=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:g" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local cpu="`get-flag march || get-flag mcpu`"
+ if [ "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "Makefile" "${PN}.pro"
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins gamedb/*.sql
+
+ dodoc README UPGRADING gamelist.xml
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythGame,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "/usr/share/mythtv/database/${PN}/nesdb.sql and "
+ einfo "/usr/share/mythtv/database/${PN}/snesdata.sql"
+ einfo "to your MythTV database in that order."
+ einfo
+ einfo "You might run in this order:"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/gamemetadata.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/nesdb.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/snesdata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}