summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-10 17:35:57 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-01-10 17:35:57 +0000
commit25a0cc624053541bf08c045f5c891002ab06b12f (patch)
tree0c90b521f6a28bf0c72483d0b2478841af6b6357 /media-plugins/live
parentDependency update: dev-util/guile -> dev-scheme/guile. (diff)
downloadgentoo-2-25a0cc624053541bf08c045f5c891002ab06b12f.tar.gz
gentoo-2-25a0cc624053541bf08c045f5c891002ab06b12f.tar.bz2
gentoo-2-25a0cc624053541bf08c045f5c891002ab06b12f.zip
Version bump.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'media-plugins/live')
-rw-r--r--media-plugins/live/ChangeLog10
-rw-r--r--media-plugins/live/files/digest-live-2007.01.093
-rw-r--r--media-plugins/live/live-2007.01.09.ebuild59
3 files changed, 70 insertions, 2 deletions
diff --git a/media-plugins/live/ChangeLog b/media-plugins/live/ChangeLog
index 1a4a04b3195e..e2ad940c4ee9 100644
--- a/media-plugins/live/ChangeLog
+++ b/media-plugins/live/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/live
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.67 2006/12/30 20:17:33 flameeyes Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/ChangeLog,v 1.68 2007/01/10 17:35:57 flameeyes Exp $
+
+*live-2007.01.09 (10 Jan 2007)
+
+ 10 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+ +live-2007.01.09.ebuild:
+ Version bump.
*live-2006.12.08 (30 Dec 2006)
diff --git a/media-plugins/live/files/digest-live-2007.01.09 b/media-plugins/live/files/digest-live-2007.01.09
new file mode 100644
index 000000000000..caa001a0b411
--- /dev/null
+++ b/media-plugins/live/files/digest-live-2007.01.09
@@ -0,0 +1,3 @@
+MD5 81322be110e78c9cec0d31393b914b99 live.2007.01.09.tar.gz 440986
+RMD160 314cdf9534a4b9f554935857aef0bcc631bc198c live.2007.01.09.tar.gz 440986
+SHA256 33fa2978d9cac2c63365ae56e1206fe4973ff44483af57d8e66f9336d816c915 live.2007.01.09.tar.gz 440986
diff --git a/media-plugins/live/live-2007.01.09.ebuild b/media-plugins/live/live-2007.01.09.ebuild
new file mode 100644
index 000000000000..3dbf4e3e7859
--- /dev/null
+++ b/media-plugins/live/live-2007.01.09.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/live/live-2007.01.09.ebuild,v 1.1 2007/01/10 17:35:57 flameeyes Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="Source-code libraries for standards-based RTP/RTCP/RTSP multimedia streaming, suitable for embedded and/or low-cost streaming applications"
+HOMEPAGE="http://www.live555.com/"
+SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"
+
+ cp -pPR live live-shared
+ mv live live-static
+
+ cp "${FILESDIR}/config.gentoo" live-static
+ cp "${FILESDIR}/config.gentoo-so" live-shared
+}
+
+src_compile() {
+ tc-export CC CXX LD
+
+ cd "${WORKDIR}/live-static"
+
+ einfo "Beginning static library build"
+ ./genMakefiles gentoo
+ emake -j1 || die
+
+ cd "${WORKDIR}/live-shared"
+ einfo "Beginning shared library build"
+ ./genMakefiles gentoo-so
+ emake -j1 || die
+}
+
+src_install() {
+ for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
+ dolib.a live-static/${library}/lib${library}.a
+ dolib.so live-shared/${library}/lib${library}.so
+
+ insinto /usr/include/${library}
+ doins live-shared/${library}/include/*h
+ done
+
+ # Should we really install these?
+ find live-shared/testProgs -type f -perm +111 -print0 | \
+ xargs -0 dobin
+
+ # install docs
+ dodoc README
+}