summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-10 18:36:48 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-10 18:36:48 +0000
commitf0626f1fb543820d3e65db02899464bbd71d9540 (patch)
treef09dbb547522d8e38fa151eae300c5b551960820 /media-libs
parentVersion bump 4.3.5, use system libjansson. Remove older 4.3.x (diff)
downloadgentoo-2-f0626f1fb543820d3e65db02899464bbd71d9540.tar.gz
gentoo-2-f0626f1fb543820d3e65db02899464bbd71d9540.tar.bz2
gentoo-2-f0626f1fb543820d3e65db02899464bbd71d9540.zip
Enable multilib support, bug #493176.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-good/ChangeLog9
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-0.10.31-r1.ebuild57
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.2.4-r1.ebuild58
3 files changed, 123 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-good/ChangeLog b/media-libs/gst-plugins-good/ChangeLog
index 1fc8b50aa382..01a38470c9bf 100644
--- a/media-libs/gst-plugins-good/ChangeLog
+++ b/media-libs/gst-plugins-good/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/gst-plugins-good
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.185 2014/05/31 14:08:55 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.186 2014/06/10 18:36:48 mgorny Exp $
+
+*gst-plugins-good-0.10.31-r1 (10 Jun 2014)
+*gst-plugins-good-1.2.4-r1 (10 Jun 2014)
+
+ 10 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +gst-plugins-good-0.10.31-r1.ebuild, +gst-plugins-good-1.2.4-r1.ebuild:
+ Enable multilib support, bug #493176.
*gst-plugins-good-1.2.4 (31 May 2014)
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-0.10.31-r1.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-0.10.31-r1.ebuild
new file mode 100644
index 000000000000..21ee64382f1a
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-0.10.31-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-0.10.31-r1.ebuild,v 1.1 2014/06/10 18:36:48 mgorny Exp $
+
+EAPI="5"
+
+GST_ORG_MODULE="gst-plugins-good"
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.24:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-0.10.36:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-0.10.36:${SLOT}[${MULTILIB_USEDEP}]
+ app-arch/bzip2[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.11[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ !<media-libs/gst-plugins-bad-0.10.22:${SLOT}
+"
+# audioparsers and qtmux moves
+
+src_configure() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ # Always enable optional bz2 support for matroska
+ # Always enable optional zlib support for qtdemux and matroska
+ # Many media files require these to work, as some container headers are often
+ # compressed, bug #291154
+ gstreamer_multilib_src_configure \
+ --enable-bz2 \
+ --enable-zlib \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.2.4-r1.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..959b3a870aed
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.2.4-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-1.2.4-r1.ebuild,v 1.1 2014/06/10 18:36:48 mgorny Exp $
+
+EAPI="5"
+
+GST_ORG_MODULE="gst-plugins-good"
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+# dtmf plugin moved from bad to good in 1.2
+RDEPEND="
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-1.2.3:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-1.2.4:${SLOT}[${MULTILIB_USEDEP}]
+ app-arch/bzip2[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+
+ !<media-libs/gst-plugins-bad-1.1:${SLOT}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_configure() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ # Always enable optional bz2 support for matroska
+ # Always enable optional zlib support for qtdemux and matroska
+ # Many media files require these to work, as some container headers are often
+ # compressed, bug #291154
+ gstreamer_multilib_src_configure \
+ --enable-bz2 \
+ --enable-zlib \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}