summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-03-03 06:03:04 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-03-03 06:03:04 +0000
commitd8eb082478a60adae1960ec4b050ad27c3c46b85 (patch)
tree173b567e1026a1e0a4a0e3223a0b373b6734952e /media-libs
parentVersion bump. (diff)
downloadgentoo-2-d8eb082478a60adae1960ec4b050ad27c3c46b85.tar.gz
gentoo-2-d8eb082478a60adae1960ec4b050ad27c3c46b85.tar.bz2
gentoo-2-d8eb082478a60adae1960ec4b050ad27c3c46b85.zip
Fix build with GCC 4.7 (bug #426368).
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/ctl/ChangeLog8
-rw-r--r--media-libs/ctl/ctl-1.4.1.ebuild5
-rw-r--r--media-libs/ctl/files/ctl-1.4.1-gcc47.patch15
3 files changed, 24 insertions, 4 deletions
diff --git a/media-libs/ctl/ChangeLog b/media-libs/ctl/ChangeLog
index c790a20b3a20..6bdf6dfbc63d 100644
--- a/media-libs/ctl/ChangeLog
+++ b/media-libs/ctl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/ctl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ChangeLog,v 1.18 2012/05/05 08:02:44 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ChangeLog,v 1.19 2013/03/03 06:03:04 dirtyepic Exp $
+
+ 03 Mar 2013; Ryan Hill <dirtyepic@gentoo.org> ctl-1.4.1.ebuild,
+ +files/ctl-1.4.1-gcc47.patch:
+ Fix build with GCC 4.7 (bug #426368).
05 May 2012; Jeff Horelick <jdhore@gentoo.org> ctl-1.4.1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/media-libs/ctl/ctl-1.4.1.ebuild b/media-libs/ctl/ctl-1.4.1.ebuild
index 12e511e6772c..cf037dee1c05 100644
--- a/media-libs/ctl/ctl-1.4.1.ebuild
+++ b/media-libs/ctl/ctl-1.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ctl-1.4.1.ebuild,v 1.13 2012/05/05 08:02:44 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ctl/ctl-1.4.1.ebuild,v 1.14 2013/03/03 06:03:04 dirtyepic Exp $
EAPI=2
inherit eutils libtool
@@ -20,6 +20,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc47.patch
elibtoolize
}
diff --git a/media-libs/ctl/files/ctl-1.4.1-gcc47.patch b/media-libs/ctl/files/ctl-1.4.1-gcc47.patch
new file mode 100644
index 000000000000..1aa4be4fe6d0
--- /dev/null
+++ b/media-libs/ctl/files/ctl-1.4.1-gcc47.patch
@@ -0,0 +1,15 @@
+ https://bugs.gentoo.org/426368
+
+ IlmCtl/CtlInterpreter.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/IlmCtl/CtlInterpreter.cpp
++++ b/IlmCtl/CtlInterpreter.cpp
+@@ -64,6 +64,7 @@
+ #include <fstream>
+ #include <algorithm>
+ #include <cassert>
++#include <unistd.h>
+
+ #ifdef WIN32
+ #include <io.h>