summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-09 14:40:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-09 14:40:23 +0000
commitc591e9299c44d6cdd2e0d021b0dcb96711f0ab4a (patch)
tree57657ed59010c275081272ff278bd602c6aca3fc /media-libs
parentVersion 0.9.1 is released (diff)
downloadgentoo-2-c591e9299c44d6cdd2e0d021b0dcb96711f0ab4a.tar.gz
gentoo-2-c591e9299c44d6cdd2e0d021b0dcb96711f0ab4a.tar.bz2
gentoo-2-c591e9299c44d6cdd2e0d021b0dcb96711f0ab4a.zip
add patch from upstream to fix build on *BSD
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog6
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.1.20-stat.patch18
-rw-r--r--media-libs/xine-lib/xine-lib-1.1.20.ebuild8
3 files changed, 29 insertions, 3 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 360f09080710..529b0161bd03 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/xine-lib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.648 2011/11/16 20:10:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.649 2011/12/09 14:40:23 aballier Exp $
+
+ 09 Dec 2011; Alexis Ballier <aballier@gentoo.org> xine-lib-1.1.20.ebuild,
+ +files/xine-lib-1.1.20-stat.patch:
+ add patch from upstream to fix build on *BSD
*xine-lib-1.1.20 (16 Nov 2011)
diff --git a/media-libs/xine-lib/files/xine-lib-1.1.20-stat.patch b/media-libs/xine-lib/files/xine-lib-1.1.20-stat.patch
new file mode 100644
index 000000000000..80e0bc36fbd8
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1.1.20-stat.patch
@@ -0,0 +1,18 @@
+# HG changeset patch
+# User Brad Smith <brad@comstyle.com>
+# Date 1321165080 0
+# Node ID 2dfa82f9ff3526e7c22dc4c316af9b1c49f67851
+# Parent 1ba56a221c164082c69180aa41e5a6b88d520f72
+Need sys/stat.h for file audio output code to build on OpenBSD
+
+diff -r 1ba56a221c16 -r 2dfa82f9ff35 src/audio_out/audio_file_out.c
+--- a/src/audio_out/audio_file_out.c Sun Nov 13 01:52:30 2011 +0000
++++ b/src/audio_out/audio_file_out.c Sun Nov 13 06:18:00 2011 +0000
+@@ -30,6 +30,7 @@
+ #include <math.h>
+ #include <unistd.h>
+ #include <inttypes.h>
++#include <sys/stat.h>
+
+ #include "xine_internal.h"
+ #include "xineutils.h"
diff --git a/media-libs/xine-lib/xine-lib-1.1.20.ebuild b/media-libs/xine-lib/xine-lib-1.1.20.ebuild
index 5ff1b35b5785..f33dd00562ee 100644
--- a/media-libs/xine-lib/xine-lib-1.1.20.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.1.20.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.20.ebuild,v 1.1 2011/11/16 20:10:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.1.20.ebuild,v 1.2 2011/12/09 14:40:23 aballier Exp $
EAPI=4
-inherit flag-o-matic toolchain-funcs multilib
+inherit flag-o-matic toolchain-funcs multilib eutils
# This should normally be empty string, unless a release has a suffix.
if [[ "${P/_pre/}" != "${P}" ]]; then
@@ -79,6 +79,10 @@ DEPEND="${RDEPEND}
sys-devel/libtool
nls? ( sys-devel/gettext )"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-stat.patch"
+}
+
src_configure() {
#prevent quicktime crashing
append-flags -frename-registers -ffunction-sections