summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-11 12:58:50 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-11 12:58:50 +0000
commitc2eb6898ad3746331b152a7e4e43f419ed72cd2d (patch)
treeba41de4d10d021b869cff65ae26e1f25bbd8ad08 /media-libs
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-c2eb6898ad3746331b152a7e4e43f419ed72cd2d.tar.gz
gentoo-2-c2eb6898ad3746331b152a7e4e43f419ed72cd2d.tar.bz2
gentoo-2-c2eb6898ad3746331b152a7e4e43f419ed72cd2d.zip
dont access $CC
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/fontconfig/fontconfig-2.1-r1.ebuild25
-rw-r--r--media-libs/fontconfig/fontconfig-2.2.1.ebuild35
-rw-r--r--media-libs/fontconfig/fontconfig-2.2.2.ebuild19
3 files changed, 27 insertions, 52 deletions
diff --git a/media-libs/fontconfig/fontconfig-2.1-r1.ebuild b/media-libs/fontconfig/fontconfig-2.1-r1.ebuild
index c13997381c83..c1b171e39993 100644
--- a/media-libs/fontconfig/fontconfig-2.1-r1.ebuild
+++ b/media-libs/fontconfig/fontconfig-2.1-r1.ebuild
@@ -1,27 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.1-r1.ebuild,v 1.22 2004/06/03 05:05:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.1-r1.ebuild,v 1.23 2004/06/11 12:58:50 vapier Exp $
-inherit debug eutils
+inherit debug eutils gcc
S="${WORKDIR}/fcpackage.${PV/\./_}/fontconfig"
-DESCRIPTION="A library for configuring and customizing font access."
+DESCRIPTION="A library for configuring and customizing font access"
HOMEPAGE="http://freedesktop.org/"
SRC_URI="http://pdx.freedesktop.org/software/fontconfig/releases/fcpackage.${PV/\./_}.tar.gz"
LICENSE="fontconfig"
SLOT="1.0"
-KEYWORDS="x86 alpha ppc sparc mips hppa amd64"
+KEYWORDS="x86 ppc sparc mips alpha hppa amd64"
+IUSE=""
# Seems like patches in freetype-2.1.2-r2 fixes bug #10028
DEPEND=">=media-libs/freetype-2.1.2-r2
>=dev-libs/expat-1.95.3
>=sys-apps/ed-0.2"
-
fc_setup() {
# Do not use 'cc' to compile
- [ ! -n "${CC}" ] && export CC="gcc" || :
+ export CC="$(gcc-getCC)"
}
src_unpack() {
@@ -69,15 +69,10 @@ src_install() {
cd ${S}
- mv fc-cache/fc-cache.man fc-cache/fc-cache.1
- mv fc-list/fc-list.man fc-list/fc-list.1
- mv src/fontconfig.man src/fontconfig.3
- for x in fc-cache/fc-cache.1 fc-list/fc-list.1 src/fontconfig.3
- do
- doman ${x}
- done
-
- dodoc AUTHORS COPYING ChangeLog NEWS README
+ newman fc-cache/fc-cache.man fc-cache.1
+ newman fc-list/fc-list.man fc-list.1
+ newman src/fontconfig.man fontconfig.3
+ dodoc AUTHORS ChangeLog NEWS README
}
pkg_postinst() {
diff --git a/media-libs/fontconfig/fontconfig-2.2.1.ebuild b/media-libs/fontconfig/fontconfig-2.2.1.ebuild
index 82f4b207cf6d..00a9ab9ac9e9 100644
--- a/media-libs/fontconfig/fontconfig-2.2.1.ebuild
+++ b/media-libs/fontconfig/fontconfig-2.2.1.ebuild
@@ -1,32 +1,23 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.2.1.ebuild,v 1.16 2004/06/02 12:44:03 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.2.1.ebuild,v 1.17 2004/06/11 12:58:50 vapier Exp $
-inherit eutils
+inherit eutils gcc
-S=${WORKDIR}/${P}
-DESCRIPTION="A library for configuring and customizing font access."
+DESCRIPTION="A library for configuring and customizing font access"
HOMEPAGE="http://freedesktop.org/Software/fontconfig"
SRC_URI="http://pdx.freedesktop.org/software/fontconfig/releases/${P}.tar.gz"
-IUSE=""
LICENSE="fontconfig"
SLOT="1.0"
-
-# Note about keywords here:
-# >=kde-base/kdebase-3.1.2 has a fix needed to work with fontconfig 2.2 and higher,
-# so don't mark this ebuild stable on archs where kde 3.1.2 is only ~.
-# this of course doesn't apply to archs where kde has no keywords at all :-)
-# -- danarmak@gentoo.org
-KEYWORDS="x86 alpha ppc sparc ~mips hppa ia64 amd64 ppc64"
+KEYWORDS="x86 ppc sparc ~mips alpha hppa amd64 ia64 ppc64"
+IUSE=""
DEPEND=">=sys-apps/sed-4
>=media-libs/freetype-2.1.4
>=dev-libs/expat-1.95.3
>=sys-apps/ed-0.2"
-MAKEOPTS="${MAKEOPTS} -j1"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -47,7 +38,6 @@ src_unpack() {
}
src_compile() {
-
[ "${ARCH}" == "alpha" -a "${CC}" == "ccc" ] && \
die "Dont compile fontconfig with ccc, it doesnt work very well"
@@ -61,7 +51,7 @@ src_compile() {
# this triggers sandbox, we do this ourselves
sed -i "s:fc-cache/fc-cache -f -v:sleep 0:" Makefile
- emake || die
+ emake -j1 || die
# remove Luxi TTF fonts from the list, the Type1 are much better
sed -i "s:<dir>/usr/X11R6/lib/X11/fonts/TTF</dir>::" fonts.conf
@@ -78,15 +68,10 @@ src_install() {
cd ${S}
- mv fc-cache/fc-cache.man fc-cache/fc-cache.1
- mv fc-list/fc-list.man fc-list/fc-list.1
- mv src/fontconfig.man src/fontconfig.3
- for x in fc-cache/fc-cache.1 fc-list/fc-list.1 src/fontconfig.3
- do
- doman ${x}
- done
-
- dodoc AUTHORS COPYING ChangeLog NEWS README
+ newman fc-cache/fc-cache.man fc-cache.1
+ newman fc-list/fc-list.man fc-list.1
+ newman src/fontconfig.man fontconfig.3
+ dodoc AUTHORS ChangeLog NEWS README
}
pkg_postinst() {
diff --git a/media-libs/fontconfig/fontconfig-2.2.2.ebuild b/media-libs/fontconfig/fontconfig-2.2.2.ebuild
index 6e70de468b25..fc7e64c249aa 100644
--- a/media-libs/fontconfig/fontconfig-2.2.2.ebuild
+++ b/media-libs/fontconfig/fontconfig-2.2.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.2.2.ebuild,v 1.5 2004/06/02 12:44:03 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.2.2.ebuild,v 1.6 2004/06/11 12:58:50 vapier Exp $
inherit eutils
-DESCRIPTION="A library for configuring and customizing font access."
+DESCRIPTION="A library for configuring and customizing font access"
HOMEPAGE="http://freedesktop.org/Software/fontconfig"
#SRC_URI="http://pdx.freedesktop.org/software/fontconfig/releases/${P}.tar.gz"
SRC_URI="http://freedesktop.org/~fontconfig/release/${P}.tar.gz"
@@ -12,13 +12,13 @@ SRC_URI="http://freedesktop.org/~fontconfig/release/${P}.tar.gz"
LICENSE="fontconfig"
SLOT="1.0"
KEYWORDS="x86 ~ppc ~sparc ~mips ~alpha arm hppa amd64 ~ia64 ~ppc64"
+IUSE=""
DEPEND=">=sys-apps/sed-4
>=media-libs/freetype-2.1.4
>=dev-libs/expat-1.95.3"
src_unpack() {
-
unpack ${A}
cd ${S}
@@ -68,15 +68,10 @@ src_install() {
cd ${S}
- mv fc-cache/fc-cache.man fc-cache/fc-cache.1
- mv fc-list/fc-list.man fc-list/fc-list.1
- mv src/fontconfig.man src/fontconfig.3
- for x in fc-cache/fc-cache.1 fc-list/fc-list.1 src/fontconfig.3
- do
- doman ${x}
- done
-
- dodoc AUTHORS COPYING ChangeLog NEWS README
+ newman fc-cache/fc-cache.man fc-cache.1
+ newman fc-list/fc-list.man fc-list.1
+ newman src/fontconfig.man fontconfig.3
+ dodoc AUTHORS ChangeLog NEWS README
}
pkg_postinst() {