summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-29 07:03:21 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-29 07:03:21 +0000
commitc2b27587547d5cf20d7acaf5466bc4669f73db64 (patch)
treee00815ee88a9d182f6de28c1071f0687ebf8a578 /media-libs
parentupdate -9999 to match vcs heads support allowing docs and man pages to be opt... (diff)
downloadgentoo-2-c2b27587547d5cf20d7acaf5466bc4669f73db64.tar.gz
gentoo-2-c2b27587547d5cf20d7acaf5466bc4669f73db64.tar.bz2
gentoo-2-c2b27587547d5cf20d7acaf5466bc4669f73db64.zip
Non-maintainer version bump, needed for shotwell bump
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gexiv2/ChangeLog9
-rw-r--r--media-libs/gexiv2/gexiv2-0.4.1.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/media-libs/gexiv2/ChangeLog b/media-libs/gexiv2/ChangeLog
index 1e2335c31cc0..d5fc495e7179 100644
--- a/media-libs/gexiv2/ChangeLog
+++ b/media-libs/gexiv2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/gexiv2
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/ChangeLog,v 1.4 2011/06/09 08:11:48 radhermit Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/ChangeLog,v 1.5 2012/03/29 07:03:21 jlec Exp $
+
+*gexiv2-0.4.1 (29 Mar 2012)
+
+ 29 Mar 2012; Justin Lecher <jlec@gentoo.org> +gexiv2-0.4.1.ebuild:
+ Non-maintainer version bump, needed for shotwell bump
*gexiv2-0.3.1 (09 Jun 2011)
diff --git a/media-libs/gexiv2/gexiv2-0.4.1.ebuild b/media-libs/gexiv2/gexiv2-0.4.1.ebuild
new file mode 100644
index 000000000000..d14326bb0be2
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/gexiv2-0.4.1.ebuild,v 1.1 2012/03/29 07:03:21 jlec Exp $
+
+EAPI=4
+
+inherit versionator multilib toolchain-funcs
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="gexiv2 is a GObject-based wrapper around the Exiv2 library."
+HOMEPAGE="http://trac.yorba.org/wiki/gexiv2/"
+SRC_URI="http://www.yorba.org/download/${PN}/${MY_PV}/lib${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=media-gfx/exiv2-0.21"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/lib${P}
+
+src_prepare() {
+ tc-export CXX
+ sed -e 's:CFLAGS:CXXFLAGS:g' -i Makefile || die
+}
+
+src_configure() {
+ ./configure --prefix=/usr || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
+}