summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-07-28 20:25:54 +0000
committerHanno Böck <hanno@gentoo.org>2010-07-28 20:25:54 +0000
commita3b3631d435dab86e57dee3bd790d84414c1afe2 (patch)
tree42db68697bca29e6d3c9e09a91bdff66a1419d18 /media-libs
parentadd ~arm, bug #321743 (diff)
downloadgentoo-2-a3b3631d435dab86e57dee3bd790d84414c1afe2.tar.gz
gentoo-2-a3b3631d435dab86e57dee3bd790d84414c1afe2.tar.bz2
gentoo-2-a3b3631d435dab86e57dee3bd790d84414c1afe2.zip
quvi bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/quvi/ChangeLog7
-rw-r--r--media-libs/quvi/quvi-0.2.1.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/media-libs/quvi/ChangeLog b/media-libs/quvi/ChangeLog
index 53aaf4ce086d..90db5109e0c9 100644
--- a/media-libs/quvi/ChangeLog
+++ b/media-libs/quvi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/quvi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/quvi/ChangeLog,v 1.4 2010/06/25 11:35:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/quvi/ChangeLog,v 1.5 2010/07/28 20:25:54 hanno Exp $
+
+*quvi-0.2.1 (28 Jul 2010)
+
+ 28 Jul 2010; Hanno Boeck <hanno@gentoo.org> +quvi-0.2.1.ebuild:
+ Version bump, restrict tests as they depend on live websites.
25 Jun 2010; Alexis Ballier <aballier@gentoo.org> quvi-0.2.0.ebuild:
depend on lua[deprecated] by Arseny Solokha <b0ntrict0r@yandex.ru>, bug
diff --git a/media-libs/quvi/quvi-0.2.1.ebuild b/media-libs/quvi/quvi-0.2.1.ebuild
new file mode 100644
index 000000000000..a196361451a8
--- /dev/null
+++ b/media-libs/quvi/quvi-0.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/quvi/quvi-0.2.1.ebuild,v 1.1 2010/07/28 20:25:54 hanno Exp $
+
+EAPI=2
+
+DESCRIPTION="library for parsing video download links"
+HOMEPAGE="http://code.google.com/p/quvi/"
+SRC_URI="http://quvi.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test offensive"
+
+RDEPEND=">=net-misc/curl-7.18.0
+ >=dev-libs/libpcre-7.9[cxx]
+ dev-lang/lua[deprecated]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# tests fetch data from live websites, so it's rather normal that they
+# will fail
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ --without-doc \
+ $(use_enable examples) \
+ $(use_enable offensive smut) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README TODO || die "dodoc failed"
+ use doc && dodoc doc/How*
+}