summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2011-10-19 16:26:12 +0000
committerLuca Barbato <lu_zero@gentoo.org>2011-10-19 16:26:12 +0000
commit76362e6990a42c0fd663a3aba628482c478e304c (patch)
treea692962d8ff546535691dc2e0a210ddf5a0a6c50 /media-libs
parentold (diff)
downloadgentoo-2-76362e6990a42c0fd663a3aba628482c478e304c.tar.gz
gentoo-2-76362e6990a42c0fd663a3aba628482c478e304c.tar.bz2
gentoo-2-76362e6990a42c0fd663a3aba628482c478e304c.zip
New version using the 118 api
(Portage version: 2.1.10.28/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/x264/ChangeLog7
-rw-r--r--media-libs/x264/x264-0.0.20111017.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index aeedb4d89f29..b814583c1083 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.61 2011/09/07 23:17:44 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.62 2011/10/19 16:26:12 lu_zero Exp $
+
+*x264-0.0.20111017 (19 Oct 2011)
+
+ 19 Oct 2011; Luca Barbato <lu_zero@gentoo.org> +x264-0.0.20111117.ebuild:
+ New version using the 118 api
*x264-0.0.20110825-r1 (07 Sep 2011)
diff --git a/media-libs/x264/x264-0.0.20111017.ebuild b/media-libs/x264/x264-0.0.20111017.ebuild
new file mode 100644
index 000000000000..fa23b1de95f1
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20111017.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20111017.ebuild,v 1.1 2011/10/19 16:26:12 lu_zero Exp $
+
+EAPI=4
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ V_ECLASS="git-2"
+else
+ V_ECLASS="versionator"
+fi
+
+inherit multilib toolchain-funcs flag-o-matic ${V_ECLASS}
+
+if [ "${PV#9999}" = "${PV}" ]; then
+ MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+fi
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ EGIT_REPO_URI="git://git.videolan.org/x264.git"
+ SRC_URI=""
+else
+ SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+fi
+IUSE="10bit custom-cflags debug +interlaced pic static-libs +threads"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+if [ "${PV#9999}" = "${PV}" ]; then
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DOCS="AUTHORS doc/*.txt"
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use 10bit && myconf+=" --bit-depth=10"
+ use debug && myconf+=" --enable-debug"
+ use interlaced || myconf+=" --disable-interlaced"
+ use static-libs && myconf+=" --enable-static"
+ use threads || myconf+=" --disable-thread"
+
+ # let upstream pick the optimization level by default
+ use custom-cflags || filter-flags -O?
+
+ if use x86 && use pic; then
+ myconf+=" --disable-asm"
+ fi
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-cli \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-ffms \
+ --disable-gpac \
+ --enable-pic \
+ --enable-shared \
+ --host="${CHOST}" \
+ ${myconf} || die
+
+ # this is a nasty workaround for bug #376925 as upstream doesn't like us
+ # fiddling with their CFLAGS
+ if use custom-cflags; then
+ local cflags
+ cflags="$(grep "^CFLAGS=" config.mak | sed 's/CFLAGS=//')"
+ cflags="${cflags//$(get-flag O)/}"
+ cflags="${cflags//-O? /$(get-flag O) }"
+ cflags="${cflags//-g /}"
+ sed -i "s:^CFLAGS=.*:CFLAGS=${cflags//:/\\:}:" config.mak
+ fi
+}