summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-05 14:56:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-05 14:56:27 +0000
commit612abbce7da170323949daf6eb6cf5329904b430 (patch)
tree36a4f259b60c633aee87da1d49e014d6bd65e938 /media-libs
parentversion bump (diff)
downloadgentoo-2-612abbce7da170323949daf6eb6cf5329904b430.tar.gz
gentoo-2-612abbce7da170323949daf6eb6cf5329904b430.tar.bz2
gentoo-2-612abbce7da170323949daf6eb6cf5329904b430.zip
version bump
(Portage version: 2.2_rc6/cvs/Linux 2.6.25.7 x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/raptor/ChangeLog7
-rw-r--r--media-libs/raptor/raptor-1.4.18.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/media-libs/raptor/ChangeLog b/media-libs/raptor/ChangeLog
index 072b236230af..df3b9023bc5b 100644
--- a/media-libs/raptor/ChangeLog
+++ b/media-libs/raptor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/raptor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.58 2008/05/12 09:39:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.59 2008/08/05 14:56:27 aballier Exp $
+
+*raptor-1.4.18 (05 Aug 2008)
+
+ 05 Aug 2008; Alexis Ballier <aballier@gentoo.org> +raptor-1.4.18.ebuild:
+ version bump
12 May 2008; Alexis Ballier <aballier@gentoo.org> raptor-1.4.16.ebuild,
raptor-1.4.17.ebuild:
diff --git a/media-libs/raptor/raptor-1.4.18.ebuild b/media-libs/raptor/raptor-1.4.18.ebuild
new file mode 100644
index 000000000000..f62adb2b50fd
--- /dev/null
+++ b/media-libs/raptor/raptor-1.4.18.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.4.18.ebuild,v 1.1 2008/08/05 14:56:27 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="The RDF Parser Toolkit"
+HOMEPAGE="http://librdf.org/raptor"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="curl unicode xml"
+
+RDEPEND="unicode? ( >=dev-libs/glib-2 )
+ xml? ( >=dev-libs/libxml2-2.6.8 )
+ !xml? ( dev-libs/expat )
+ curl? ( net-misc/curl )
+ dev-libs/libxslt"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf=""
+
+ if use xml; then
+ myconf="${myconf} --with-xml-parser=libxml"
+ else
+ myconf="${myconf} --with-xml-parser=expat"
+ fi
+
+ if use curl; then
+ myconf="${myconf} --with-www=curl"
+ elif use xml; then
+ myconf="${myconf} --with-www=xml"
+ else
+ myconf="${myconf} --with-www=none"
+ fi
+
+ econf $(use_enable unicode nfc-check) \
+ ${myconf}
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS NOTICE README
+ dohtml NEWS.html README.html RELEASE.html
+}