summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-02-29 01:12:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-02-29 01:12:55 +0000
commit4c8c434b6147899d892aed31919a15a6421187d1 (patch)
treef118f6e924ca6887db2316f51eb045fb58945516 /media-libs
parentRemove old. (diff)
downloadgentoo-2-4c8c434b6147899d892aed31919a15a6421187d1.tar.gz
gentoo-2-4c8c434b6147899d892aed31919a15a6421187d1.tar.bz2
gentoo-2-4c8c434b6147899d892aed31919a15a6421187d1.zip
add upstream patch to fix build with ffmpeg git
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog6
-rw-r--r--media-libs/xine-lib/files/xine-lib-1.2.1-ffmpeg-git.patch75
-rw-r--r--media-libs/xine-lib/xine-lib-1.2.1.ebuild5
3 files changed, 83 insertions, 3 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 9b1145349d5c..ecf4e0934685 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/xine-lib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.667 2012/02/28 22:20:23 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.668 2012/02/29 01:12:55 aballier Exp $
+
+ 28 Feb 2012; Alexis Ballier <aballier@gentoo.org> xine-lib-1.2.1.ebuild,
+ +files/xine-lib-1.2.1-ffmpeg-git.patch:
+ add upstream patch to fix build with ffmpeg git
28 Feb 2012; Brent Baude <ranger@gentoo.org> xine-lib-1.2.1.ebuild:
Marking xine-lib-1.2.1 ppc for bug 405659
diff --git a/media-libs/xine-lib/files/xine-lib-1.2.1-ffmpeg-git.patch b/media-libs/xine-lib/files/xine-lib-1.2.1-ffmpeg-git.patch
new file mode 100644
index 000000000000..c036a0ec9fa0
--- /dev/null
+++ b/media-libs/xine-lib/files/xine-lib-1.2.1-ffmpeg-git.patch
@@ -0,0 +1,75 @@
+# HG changeset patch
+# User Edgar Hucek <ebsi4711@gmail.com>
+# Date 1327873178 -3600
+# Node ID 69983efb1c928e64cc1900579b98142cef0569c4
+# Parent 61f51ebc2659363e308bedb10b9fa4e71a60cedc
+fix compile against recent ffmpeg
+
+diff -r 61f51ebc2659 -r 69983efb1c92 src/combined/ffmpeg/ff_video_decoder.c
+--- a/src/combined/ffmpeg/ff_video_decoder.c Sat Feb 04 18:52:01 2012 +0000
++++ b/src/combined/ffmpeg/ff_video_decoder.c Sun Jan 29 22:39:38 2012 +0100
+@@ -130,7 +130,9 @@
+
+ yuv_planes_t yuv;
+
++#ifdef AVPaletteControl
+ AVPaletteControl palette_control;
++#endif
+
+ #ifdef LOG
+ enum PixelFormat debug_fmt;
+@@ -218,7 +220,9 @@
+ /* We should really keep track of the ages of xine frames (see
+ * avcodec_default_get_buffer in libavcodec/utils.c)
+ * For the moment tell ffmpeg that every frame is new (age = bignumber) */
++#ifdef AVFRAMEAGE
+ av_frame->age = 256*256*256*64;
++#endif
+
+ av_frame->type= FF_BUFFER_TYPE_USER;
+
+@@ -1028,7 +1032,9 @@
+ memcpy(this->context->extradata, buf->decoder_info_ptr[2],
+ buf->decoder_info[2]);
+
+- } else if (buf->decoder_info[1] == BUF_SPECIAL_PALETTE) {
++ }
++#ifdef AVPaletteControl
++ else if (buf->decoder_info[1] == BUF_SPECIAL_PALETTE) {
+ unsigned int i;
+
+ palette_entry_t *demuxer_palette;
+@@ -1047,7 +1053,9 @@
+ }
+ decoder_palette->palette_changed = 1;
+
+- } else if (buf->decoder_info[1] == BUF_SPECIAL_RV_CHUNK_TABLE) {
++ }
++#endif
++ else if (buf->decoder_info[1] == BUF_SPECIAL_RV_CHUNK_TABLE) {
+ int i;
+
+ lprintf("BUF_SPECIAL_RV_CHUNK_TABLE\n");
+@@ -1794,7 +1802,9 @@
+ this->av_frame = avcodec_alloc_frame();
+ this->context = avcodec_alloc_context();
+ this->context->opaque = this;
++#ifdef AVPaletteControl
+ this->context->palctrl = NULL;
++#endif
+
+ this->decoder_ok = 0;
+ this->decoder_init_mode = 1;
+diff -r 61f51ebc2659 -r 69983efb1c92 src/combined/ffmpeg/ffmpeg_compat.h
+--- a/src/combined/ffmpeg/ffmpeg_compat.h Sat Feb 04 18:52:01 2012 +0000
++++ b/src/combined/ffmpeg/ffmpeg_compat.h Sun Jan 29 22:39:38 2012 +0100
+@@ -91,5 +91,9 @@
+ # define AVAUDIO 2
+ #endif
+
++/* AVFrame.age */
++#if !(LIBAVCODEC_VERSION_MAJOR >= 53 && LIBAVCODEC_VERSION_MAJOR >= 28 && LIBAVCODEC_VERSION_MICRO >= 1)
++# define AVFRAMEAGE 1
++#endif
+
+ #endif /* XINE_AVCODEC_COMPAT_H */
diff --git a/media-libs/xine-lib/xine-lib-1.2.1.ebuild b/media-libs/xine-lib/xine-lib-1.2.1.ebuild
index c164fd89f21f..ac5757367afb 100644
--- a/media-libs/xine-lib/xine-lib-1.2.1.ebuild
+++ b/media-libs/xine-lib/xine-lib-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.2.1.ebuild,v 1.4 2012/02/28 22:20:23 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1.2.1.ebuild,v 1.5 2012/02/29 01:12:55 aballier Exp $
EAPI=4
@@ -14,7 +14,7 @@ else
SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"
fi
-inherit libtool multilib ${_live_inherits}
+inherit eutils libtool multilib ${_live_inherits}
DESCRIPTION="Core libraries for Xine movie player"
HOMEPAGE="http://xine.sourceforge.net/"
@@ -113,6 +113,7 @@ REQUIRED_USE="vidix? ( || ( X fbcon ) )
xinerama? ( X )"
src_prepare() {
+ epatch "${FILESDIR}/${P}-ffmpeg-git.patch"
sed -i -e '/define VDR_ABS_FIFO_DIR/s|".*"|"/var/vdr/xine"|' src/vdr/input_vdr.c || die
if [[ ${PV} == *9999* ]]; then