summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2004-09-20 18:09:40 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2004-09-20 18:09:40 +0000
commit3c9bdd50bd129a3fc3d8307088dedea801f6667a (patch)
treeb3013ec1e7854b5a1dfeb68488340d1c874551ca /media-libs
parentmark stable on x86 (Manifest recommit) (diff)
downloadgentoo-2-3c9bdd50bd129a3fc3d8307088dedea801f6667a.tar.gz
gentoo-2-3c9bdd50bd129a3fc3d8307088dedea801f6667a.tar.bz2
gentoo-2-3c9bdd50bd129a3fc3d8307088dedea801f6667a.zip
Stable on sparc wrt #64348, also pulled in a sparc32 thingy that should hopefully allow it to compile
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/xine-lib/ChangeLog6
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc6.ebuild12
2 files changed, 14 insertions, 4 deletions
diff --git a/media-libs/xine-lib/ChangeLog b/media-libs/xine-lib/ChangeLog
index 902913867c24..af82aa10a135 100644
--- a/media-libs/xine-lib/ChangeLog
+++ b/media-libs/xine-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/xine-lib
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.146 2004/09/20 11:56:13 sejo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/ChangeLog,v 1.147 2004/09/20 18:09:40 gustavoz Exp $
+
+ 20 Sep 2004; Gustavo Zacarias <gustavoz@gentoo.org> xine-lib-1_rc6.ebuild:
+ Stable on sparc wrt #64348, also pulled in a sparc32 thingy that should
+ hopefully allow it to compile
20 Sep 2004; <SeJo@gentoo.org> xine-lib-1_rc6.ebuild:
marked ppc gsla bug: 64348
diff --git a/media-libs/xine-lib/xine-lib-1_rc6.ebuild b/media-libs/xine-lib/xine-lib-1_rc6.ebuild
index 329de0e2621c..2caff6d9f175 100644
--- a/media-libs/xine-lib/xine-lib-1_rc6.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc6.ebuild,v 1.5 2004/09/20 11:56:13 sejo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc6.ebuild,v 1.6 2004/09/20 18:09:40 gustavoz Exp $
inherit eutils flag-o-matic gcc libtool
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/xine/${PN}-${PV/_/-}${MY_PKG_SUFFIX}.tar.gz"
LICENSE="GPL-2"
SLOT="1"
-KEYWORDS="x86 ppc ~sparc alpha ~hppa amd64 ~ia64 ~ppc64"
+KEYWORDS="x86 ppc sparc alpha ~hppa amd64 ~ia64 ~ppc64"
IUSE="arts esd avi nls dvd aalib X directfb oggvorbis alsa gnome sdl speex theora ipv6 altivec"
RDEPEND="oggvorbis? ( media-libs/libvorbis )
@@ -115,7 +115,13 @@ src_compile() {
# && myconf="${myconf} --with-external-ffmpeg"
use sparc \
- && myconf="${myconf} --enable-vis --build=${CHOST}"
+ && myconf="${myconf} --build=${CHOST}"
+
+ # enable/disable appropiate optimizations on sparc
+ [ "${PROFILE_ARCH}" == "sparc64" ] \
+ && myconf="${myconf} --enable-vis"
+ [ "${PROFILE_ARCH}" == "sparc" ] \
+ && myconf="${myconf} --disable-vis"
use amd64 \
&& myconf="${myconf} --with-xv-path=/usr/X11R6/$(get_libdir)"