summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2014-03-13 23:21:42 +0000
committerMatt Turner <mattst88@gentoo.org>2014-03-13 23:21:42 +0000
commit342594bfa93949678643ff210b1525c3bfe10971 (patch)
tree057496c09d86fa2c192d8b30c3e9dc3afaf4fc88 /media-libs
parentversion bump (diff)
downloadgentoo-2-342594bfa93949678643ff210b1525c3bfe10971.tar.gz
gentoo-2-342594bfa93949678643ff210b1525c3bfe10971.tar.bz2
gentoo-2-342594bfa93949678643ff210b1525c3bfe10971.zip
Add dri3 USE flag, and add udev as a dependency, bug #504356.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/ChangeLog6
-rw-r--r--media-libs/mesa/mesa-10.1.0.ebuild12
-rw-r--r--media-libs/mesa/metadata.xml1
3 files changed, 14 insertions, 5 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 47d912717d1b..c894c1154e0d 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.543 2014/03/09 18:38:01 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.544 2014/03/13 23:21:42 mattst88 Exp $
+
+ 13 Mar 2014; Matt Turner <mattst88@gentoo.org> mesa-10.1.0.ebuild,
+ metadata.xml:
+ Add dri3 USE flag, and add udev as a dependency, bug #504356.
09 Mar 2014; Matt Turner <mattst88@gentoo.org> mesa-10.1.0.ebuild:
Update libxshmfence dependency to 1.1, bug #503932.
diff --git a/media-libs/mesa/mesa-10.1.0.ebuild b/media-libs/mesa/mesa-10.1.0.ebuild
index 2a219592855a..98c209f3b119 100644
--- a/media-libs/mesa/mesa-10.1.0.ebuild
+++ b/media-libs/mesa/mesa-10.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-10.1.0.ebuild,v 1.3 2014/03/09 18:38:01 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-10.1.0.ebuild,v 1.4 2014/03/13 23:21:42 mattst88 Exp $
EAPI=5
@@ -49,7 +49,7 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- bindist +classic debug +egl +gallium gbm gles1 gles2 +llvm +nptl
+ bindist +classic debug +dri3 +egl +gallium gbm gles1 gles2 +llvm +nptl
+llvm-shared-libs opencl openvg osmesa pax_kernel pic
r600-llvm-compiler selinux vdpau wayland xvmc xa kernel_FreeBSD"
@@ -95,6 +95,7 @@ RDEPEND="
>=app-admin/eselect-opengl-1.2.7
dev-libs/expat[${MULTILIB_USEDEP}]
gbm? ( virtual/udev[${MULTILIB_USEDEP}] )
+ dri3? ( virtual/udev[${MULTILIB_USEDEP}] )
>=x11-libs/libX11-1.3.99.901[${MULTILIB_USEDEP}]
>=x11-libs/libxshmfence-1.1[${MULTILIB_USEDEP}]
x11-libs/libXdamage[${MULTILIB_USEDEP}]
@@ -154,8 +155,10 @@ DEPEND="${RDEPEND}
sys-devel/flex
virtual/pkgconfig
>=x11-proto/dri2proto-2.6[${MULTILIB_USEDEP}]
- >=x11-proto/dri3proto-1.0[${MULTILIB_USEDEP}]
- >=x11-proto/presentproto-1.0[${MULTILIB_USEDEP}]
+ dri3? (
+ >=x11-proto/dri3proto-1.0[${MULTILIB_USEDEP}]
+ >=x11-proto/presentproto-1.0[${MULTILIB_USEDEP}]
+ )
>=x11-proto/glproto-1.4.15-r1[${MULTILIB_USEDEP}]
>=x11-proto/xextproto-7.0.99.1[${MULTILIB_USEDEP}]
x11-proto/xf86driproto[${MULTILIB_USEDEP}]
@@ -311,6 +314,7 @@ multilib_src_configure() {
--enable-shared-glapi \
$(use_enable !bindist texture-float) \
$(use_enable debug) \
+ $(use_enable dri3) \
$(use_enable egl) \
$(use_enable gbm) \
$(use_enable gles1) \
diff --git a/media-libs/mesa/metadata.xml b/media-libs/mesa/metadata.xml
index d68ad0295f6f..efcc9529da6d 100644
--- a/media-libs/mesa/metadata.xml
+++ b/media-libs/mesa/metadata.xml
@@ -5,6 +5,7 @@
<use>
<flag name='bindist'>Disable patent-encumbered ARB_texture_float, EXT_texture_shared_exponent, and EXT_packed_float extensions.</flag>
<flag name='classic'>Build drivers based on the classic architecture.</flag>
+ <flag name='dri3'>Enable DRI3 support.</flag>
<flag name='egl'>Enable EGL support.</flag>
<flag name='gallium'>Build drivers based on Gallium3D, the new architecture for 3D graphics drivers.</flag>
<flag name='g3dvl'>Enable video decode acceleration support for Gallium3D.</flag>