summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-01-16 17:06:58 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-01-16 17:06:58 +0000
commit002848dd3db80ad078ea23df8daecd1038d523b3 (patch)
tree0b623fe9dc685941b71bd81d61d2603956927d82 /media-libs
parentversion bump (diff)
downloadgentoo-2-002848dd3db80ad078ea23df8daecd1038d523b3.tar.gz
gentoo-2-002848dd3db80ad078ea23df8daecd1038d523b3.tar.bz2
gentoo-2-002848dd3db80ad078ea23df8daecd1038d523b3.zip
using epach and fixed 1.0.15's diff
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libpng/ChangeLog7
-rw-r--r--media-libs/libpng/files/libpng-1.0.15-gentoo.diff15
-rw-r--r--media-libs/libpng/libpng-1.0.15.ebuild11
-rw-r--r--media-libs/libpng/libpng-1.2.5-r2.ebuild10
4 files changed, 29 insertions, 14 deletions
diff --git a/media-libs/libpng/ChangeLog b/media-libs/libpng/ChangeLog
index 1a6da6140546..c51f4910dd0e 100644
--- a/media-libs/libpng/ChangeLog
+++ b/media-libs/libpng/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for media-libs/libpng
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/ChangeLog,v 1.19 2003/01/15 20:17:33 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/ChangeLog,v 1.20 2003/01/16 17:06:58 seemant Exp $
*libpng-1.0.15 (14 Jan 2003)
+ 16 Jan 2003; Seemant Kulleen <seemant@gentoo.org> libpng-1.0.15.ebuild
+ libpng-1.2.5-r2.ebuild files/libpng-1.0.15-gentoo.diff :
+
+ fixed the diff and using epatch
+
15 Jan 2003; Seemant Kulleen <seemant@gentoo.org>
files/libpng-1.0.15-gentoo.diff :
diff --git a/media-libs/libpng/files/libpng-1.0.15-gentoo.diff b/media-libs/libpng/files/libpng-1.0.15-gentoo.diff
index 7a5a2404c842..60604a458a5e 100644
--- a/media-libs/libpng/files/libpng-1.0.15-gentoo.diff
+++ b/media-libs/libpng/files/libpng-1.0.15-gentoo.diff
@@ -1,6 +1,7 @@
---- libpng-1.0.12.orig/pngconf.h
-+++ libpng-1.0.12/pngconf.h
-@@ -243,8 +243,13 @@
+diff -urN libpng-1.0.15-old/pngconf.h libpng-1.0.15/pngconf.h
+--- libpng-1.0.15-old/pngconf.h 2002-10-03 04:13:12.000000000 -0700
++++ libpng-1.0.15/pngconf.h 2003-01-16 08:57:40.000000000 -0800
+@@ -254,8 +254,13 @@
# undef _BSD_SOURCE
# endif
# ifdef _SETJMP_H
@@ -16,8 +17,10 @@
# endif
# endif /* __linux__ */
-+++ libpng-1.0.12/pngrtran.c
-@@ -1924,8 +1924,8 @@
+diff -urN libpng-1.0.15-old/pngrtran.c libpng-1.0.15/pngrtran.c
+--- libpng-1.0.15-old/pngrtran.c 2002-10-03 04:13:15.000000000 -0700
++++ libpng-1.0.15/pngrtran.c 2003-01-16 08:57:40.000000000 -0800
+@@ -1965,8 +1965,8 @@
/* This changes the data from RRGGBB to RRGGBBXX */
if (flags & PNG_FLAG_FILLER_AFTER)
{
@@ -28,7 +31,7 @@
for (i = 1; i < row_width; i++)
{
*(--dp) = hi_filler;
-@@ -1946,8 +1946,8 @@
+@@ -1987,8 +1987,8 @@
/* This changes the data from RRGGBB to XXRRGGBB */
else
{
diff --git a/media-libs/libpng/libpng-1.0.15.ebuild b/media-libs/libpng/libpng-1.0.15.ebuild
index 4e2ffcdf6ffb..07c510c3fe85 100644
--- a/media-libs/libpng/libpng-1.0.15.ebuild
+++ b/media-libs/libpng/libpng-1.0.15.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.0.15.ebuild,v 1.2 2003/01/16 13:13:15 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.0.15.ebuild,v 1.3 2003/01/16 17:06:58 seemant Exp $
+
+inherit flag-o-matic eutils
S=${WORKDIR}/${P}
DESCRIPTION="Portable Networks Graphics library."
@@ -16,14 +18,17 @@ src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ replace-flags "-march=k6-3" "-march=i586"
+ replace-flags "-march=k6-2" "-march=i586"
+ replace-flags "-march=k6" "-march=i586"
sed -e "s:ZLIBLIB=../zlib:ZLIBLIB=/usr/lib:" \
-e "s:ZLIBINC=../zlib:ZLIBINC=/usr/include:" \
-e "s:prefix=/usr:prefix=${D}/usr:" \
-e "s/-O3/${CFLAGS}/" \
scripts/makefile.linux > Makefile
-
}
src_compile() {
diff --git a/media-libs/libpng/libpng-1.2.5-r2.ebuild b/media-libs/libpng/libpng-1.2.5-r2.ebuild
index 9f21b9ec9621..fa664472e849 100644
--- a/media-libs/libpng/libpng-1.2.5-r2.ebuild
+++ b/media-libs/libpng/libpng-1.2.5-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.5-r2.ebuild,v 1.1 2003/01/08 14:26:45 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.2.5-r2.ebuild,v 1.2 2003/01/16 17:06:58 seemant Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
S=${WORKDIR}/${P}
DESCRIPTION="Portable Network Graphics library"
@@ -19,9 +19,11 @@ src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-gentoo.diff
- replace-flags "-march=k6*" "-march=i586"
+ replace-flags "-march=k6-3" "-march=i586"
+ replace-flags "-march=k6-2" "-march=i586"
+ replace-flags "-march=k6" "-march=i586"
sed -e "s:ZLIBLIB=.*:ZLIBLIB=/usr/lib:" \
-e "s:ZLIBINC=.*:ZLIBINC=/usr/include:" \