summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-17 07:01:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-17 07:01:14 +0000
commit24c0f8f4cfb6a68fc2fa07432fbf4aea43e010b0 (patch)
tree2104a96418daa386ac6c258c8ae7b66f7611a663 /media-libs/slv2/slv2-0.6.6.ebuild
parentnet-misc/l7-filter masked for removal, bug 274341 and bug 254086. (diff)
downloadgentoo-2-24c0f8f4cfb6a68fc2fa07432fbf4aea43e010b0.tar.gz
gentoo-2-24c0f8f4cfb6a68fc2fa07432fbf4aea43e010b0.tar.bz2
gentoo-2-24c0f8f4cfb6a68fc2fa07432fbf4aea43e010b0.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/slv2/slv2-0.6.6.ebuild')
-rw-r--r--media-libs/slv2/slv2-0.6.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-libs/slv2/slv2-0.6.6.ebuild b/media-libs/slv2/slv2-0.6.6.ebuild
new file mode 100644
index 000000000000..054416dbc57b
--- /dev/null
+++ b/media-libs/slv2/slv2-0.6.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/slv2/slv2-0.6.6.ebuild,v 1.1 2009/06/17 07:01:14 aballier Exp $
+
+EAPI=2
+
+inherit multilib toolchain-funcs eutils
+
+DESCRIPTION="A library to make the use of LV2 plugins as simple as possible for applications"
+HOMEPAGE="http://wiki.drobilla.net/SLV2"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jack"
+
+RDEPEND=">=dev-libs/redland-1.0.6
+ jack? ( >=media-sound/jack-audio-connection-kit-0.107.0 )
+ media-libs/lv2core"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/ldconfig.patch"
+}
+
+src_configure() {
+ tc-export CC CXX CPP AR RANLIB
+ ./waf configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir)/ \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use doc && echo "--build-docs") \
+ $(use jack || echo "--no-jack") \
+ || die "failed to configure"
+}
+
+src_compile() {
+ ./waf || die "failed to build"
+}
+
+src_install() {
+ ./waf --destdir="${D}" install || die "install failed"
+ dodoc AUTHORS README ChangeLog
+}