summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-10-15 04:36:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-10-15 04:36:38 +0000
commite27dee7ac4a22e725eba0ed6d3750dfbba556218 (patch)
treedbf9beed5bbb3ba917333fec269b7779e4601a84 /media-libs/sdl-sound
parentnew version (diff)
downloadgentoo-2-e27dee7ac4a22e725eba0ed6d3750dfbba556218.tar.gz
gentoo-2-e27dee7ac4a22e725eba0ed6d3750dfbba556218.tar.bz2
gentoo-2-e27dee7ac4a22e725eba0ed6d3750dfbba556218.zip
add patch to fix up the problems gcc 3.3.1 has with the configure script. (bug 31163)
Diffstat (limited to 'media-libs/sdl-sound')
-rw-r--r--media-libs/sdl-sound/ChangeLog7
-rw-r--r--media-libs/sdl-sound/Manifest5
-rw-r--r--media-libs/sdl-sound/files/gcc331.patch23
-rw-r--r--media-libs/sdl-sound/sdl-sound-1.0.1.ebuild17
4 files changed, 48 insertions, 4 deletions
diff --git a/media-libs/sdl-sound/ChangeLog b/media-libs/sdl-sound/ChangeLog
index 3f7a243333b3..26ac1c1c1048 100644
--- a/media-libs/sdl-sound/ChangeLog
+++ b/media-libs/sdl-sound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sdl-sound
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/ChangeLog,v 1.10 2003/10/14 08:01:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/ChangeLog,v 1.11 2003/10/15 04:36:25 mr_bones_ Exp $
+
+ 14 Oct 2003; Michael Sterrett <mr_bones_@gentoo.org> sdl-sound-1.0.1.ebuild,
+ files/gcc331.patch:
+ add patch to fix up the problems gcc 3.3.1 has with the configure script.
+ This is to address bug 31163.
*sdl-sound-1.0.1 (14 Oct 2003)
diff --git a/media-libs/sdl-sound/Manifest b/media-libs/sdl-sound/Manifest
index 45b6d0d2ea69..dc9cbeea59b7 100644
--- a/media-libs/sdl-sound/Manifest
+++ b/media-libs/sdl-sound/Manifest
@@ -1,7 +1,8 @@
-MD5 6450f4ddb48fcaf284301a8a8eae4849 ChangeLog 1531
+MD5 81c18b935f67e9534fbecbc94c60af92 ChangeLog 1741
MD5 86a0b6527e115107e018a152a83b47e1 sdl-sound-0.1.5.ebuild 849
MD5 0847dd30cb6a6409cd9a22c1ae126462 sdl-sound-1.0.0.ebuild 855
-MD5 a1c2fbcd89f194044c6164019e5e7bcf sdl-sound-1.0.1.ebuild 994
+MD5 e4c10d84033826821eb397ffb906e393 sdl-sound-1.0.1.ebuild 1333
MD5 82a479faa5dc89a39459aedfc2a50f4d files/digest-sdl-sound-0.1.5 67
MD5 0c12512e023bf03f6deaf00e8985b830 files/digest-sdl-sound-1.0.0 67
MD5 ac57f8a9a3aceed84463057baf569ddf files/digest-sdl-sound-1.0.1 68
+MD5 8bbc02320ecd20c8a7ed18a63f317ca1 files/gcc331.patch 1235
diff --git a/media-libs/sdl-sound/files/gcc331.patch b/media-libs/sdl-sound/files/gcc331.patch
new file mode 100644
index 000000000000..a4021d1359c6
--- /dev/null
+++ b/media-libs/sdl-sound/files/gcc331.patch
@@ -0,0 +1,23 @@
+--- acinclude.m4.orig 2003-01-12 14:03:14.000000000 -0800
++++ acinclude.m4 2003-10-14 18:33:09.000000000 -0700
+@@ -587,16 +587,11 @@
+ }
+ else
+ {
+- printf("\n*** 'smpeg-config --version' returned %d.%d.%d, but the
+-minimum version\n", $smpeg_major_version, $smpeg_minor_version,
+-$smpeg_micro_version);
+- printf("*** of SMPEG required is %d.%d.%d. If smpeg-config is
+-correct, then it is\n", major, minor, micro);
++ printf("\n*** 'smpeg-config --version' returned %d.%d.%d, but the minimum version\n", $smpeg_major_version, $smpeg_minor_version, $smpeg_micro_version);
++ printf("*** of SMPEG required is %d.%d.%d. If smpeg-config is correct, then it is\n", major, minor, micro);
+ printf("*** best to upgrade to the required version.\n");
+- printf("*** If smpeg-config was wrong, set the environment variable
+-SMPEG_CONFIG\n");
+- printf("*** to point to the correct copy of smpeg-config, and remove
+-the file\n");
++ printf("*** If smpeg-config was wrong, set the environment variable SMPEG_CONFIG\n");
++ printf("*** to point to the correct copy of smpeg-config, and remove the file\n");
+ printf("*** config.cache before re-running configure\n");
+ return 1;
+ }
diff --git a/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild b/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild
index a96d4a56c268..46ce71c9b1b3 100644
--- a/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild
+++ b/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild,v 1.1 2003/10/14 08:01:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-sound/sdl-sound-1.0.1.ebuild,v 1.2 2003/10/15 04:36:25 mr_bones_ Exp $
MY_P="${P/sdl-/SDL_}"
S=${WORKDIR}/${MY_P}
@@ -20,7 +20,22 @@ DEPEND=">=media-libs/libsdl-1.2
IUSE="flac mikmod oggvorbis"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gcc331.patch
+ rm aclocal.m4
+}
+
src_compile() {
+ # the patch above plus this overkill ripped off the bootstrap scipt from
+ # the sdl_sound CVS to address bug 31163 until the next release.
+ aclocal
+ libtoolize --automake --copy --force
+ autoheader
+ automake --foreign --add-missing --copy
+ autoconf
+
econf \
`use_enable flac` \
`use_enable mikmod` \