summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-08-07 08:24:50 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-08-07 08:24:50 +0000
commitf581e82b7db7904418d677aebf33c55f9459fbd0 (patch)
tree808e0a723ef73ecd09d3ffd8ccda337dd9b6ed95 /media-libs/resid
parentAdded support for use var: opengl. Fixes #5025. Submitted by Caleb Shay (diff)
downloadgentoo-2-f581e82b7db7904418d677aebf33c55f9459fbd0.tar.gz
gentoo-2-f581e82b7db7904418d677aebf33c55f9459fbd0.tar.bz2
gentoo-2-f581e82b7db7904418d677aebf33c55f9459fbd0.zip
New package. Fixes #5567. Contributed by Hanno Boeck
Diffstat (limited to 'media-libs/resid')
-rw-r--r--media-libs/resid/ChangeLog16
-rw-r--r--media-libs/resid/files/digest-resid-0.131
-rw-r--r--media-libs/resid/resid-0.13.ebuild26
3 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/resid/ChangeLog b/media-libs/resid/ChangeLog
new file mode 100644
index 000000000000..fffee0614c34
--- /dev/null
+++ b/media-libs/resid/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for media-libs/resid
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-libs/resid/ChangeLog,v 1.1 2002/08/07 08:24:50 rphillips Exp $
+
+*resid-0.13 (7 Aug 2002)
+
+ 7 Aug 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Submitted by Hanno Boeck
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
diff --git a/media-libs/resid/files/digest-resid-0.13 b/media-libs/resid/files/digest-resid-0.13
new file mode 100644
index 000000000000..8efc4d050592
--- /dev/null
+++ b/media-libs/resid/files/digest-resid-0.13
@@ -0,0 +1 @@
+MD5 1e7865415b2d0c89a03fb378394d48b3 resid-0.13.tgz 236802
diff --git a/media-libs/resid/resid-0.13.ebuild b/media-libs/resid/resid-0.13.ebuild
new file mode 100644
index 000000000000..b7c6e21f0472
--- /dev/null
+++ b/media-libs/resid/resid-0.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/resid/resid-0.13.ebuild,v 1.1 2002/08/07 08:24:50 rphillips Exp $
+
+DESCRIPTION="C++ library to emulate the C64 SID chip"
+HOMEPAGE="http://sidplay2.sourceforge.net"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/sidplay2/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+DEPEND=""
+RDEPEND="${DEPEND}"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+}