summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-06 14:57:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-06 14:57:12 +0000
commitbad16eedf3063cbec95384564f21e5b5b682298a (patch)
treed58f75938ce169e4c1a764d5057998365c554919 /media-libs/openinventor
parentremove mod_auth_pam from p.mask, it no longer exists (diff)
downloadgentoo-2-bad16eedf3063cbec95384564f21e5b5b682298a.tar.gz
gentoo-2-bad16eedf3063cbec95384564f21e5b5b682298a.tar.bz2
gentoo-2-bad16eedf3063cbec95384564f21e5b5b682298a.zip
Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #277081.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/openinventor')
-rw-r--r--media-libs/openinventor/ChangeLog7
-rw-r--r--media-libs/openinventor/files/openinventor-2.1.5.10-glibc-2.10.patch26
-rw-r--r--media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild25
3 files changed, 41 insertions, 17 deletions
diff --git a/media-libs/openinventor/ChangeLog b/media-libs/openinventor/ChangeLog
index 8c2420652157..103737a9eade 100644
--- a/media-libs/openinventor/ChangeLog
+++ b/media-libs/openinventor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/openinventor
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/ChangeLog,v 1.27 2009/02/07 21:11:28 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/ChangeLog,v 1.28 2009/08/06 14:57:11 ssuominen Exp $
+
+ 06 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ openinventor-2.1.5.10-r3.ebuild,
+ +files/openinventor-2.1.5.10-glibc-2.10.patch:
+ Fix building with GCC 4.4+ and GLIBC 2.10+ wrt #277081.
07 Feb 2009; Markus Meier <maekke@gentoo.org>
openinventor-2.1.5.10-r3.ebuild:
diff --git a/media-libs/openinventor/files/openinventor-2.1.5.10-glibc-2.10.patch b/media-libs/openinventor/files/openinventor-2.1.5.10-glibc-2.10.patch
new file mode 100644
index 000000000000..ad6c336aeb85
--- /dev/null
+++ b/media-libs/openinventor/files/openinventor-2.1.5.10-glibc-2.10.patch
@@ -0,0 +1,26 @@
+diff -ur inventor.orig/lib/database/src/so/SoInput.c++ inventor/lib/database/src/so/SoInput.c++
+--- inventor.orig/lib/database/src/so/SoInput.c++ 2000-10-26 02:47:47.000000000 +0300
++++ inventor/lib/database/src/so/SoInput.c++ 2009-08-06 17:50:59.000000000 +0300
+@@ -2810,7 +2810,7 @@
+
+ if (addToGlobalDict) {
+ // Look for the first '+':
+- char *firstPlus = strchr(n, '+');
++ const char *firstPlus = strchr(n, '+');
+
+ if (firstPlus == NULL) {
+ base->setName(name);
+diff -ur inventor.orig/lib/interaction/src/nodekits/SoInteractionKit.c++ inventor/lib/interaction/src/nodekits/SoInteractionKit.c++
+--- inventor.orig/lib/interaction/src/nodekits/SoInteractionKit.c++ 2000-08-15 15:56:25.000000000 +0300
++++ inventor/lib/interaction/src/nodekits/SoInteractionKit.c++ 2009-08-06 17:55:56.000000000 +0300
+@@ -854,8 +854,8 @@
+ // (as in "childList[0].appearance")
+ // If so, get the string up to whichever came first.
+ // This will be the 'intermediary' we look for.
+- char *dotPtr = strchr( partName.getString(), '.' );
+- char *brackPtr = strchr( partName.getString(), '[' );
++ const char *dotPtr = strchr( partName.getString(), '.' );
++ const char *brackPtr = strchr( partName.getString(), '[' );
+
+ if ( dotPtr != NULL || brackPtr != NULL ) {
+ char *nameCopy = strdup( partName.getString() );
diff --git a/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild b/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild
index 1a12c78964ad..f83e1e9c6bab 100644
--- a/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild
+++ b/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild,v 1.5 2009/02/07 21:11:28 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/openinventor-2.1.5.10-r3.ebuild,v 1.6 2009/08/06 14:57:11 ssuominen Exp $
+EAPI=2
inherit eutils versionator flag-o-matic toolchain-funcs
MY_PV=$(replace_version_separator 3 '-')
-MY_PN="inventor"
+MY_PN=inventor
DESCRIPTION="SGI OpenInventor Toolkit and Utilities"
HOMEPAGE="http://oss.sgi.com/projects/inventor/"
@@ -16,25 +17,15 @@ SLOT="0"
KEYWORDS="alpha amd64 sparc x86"
IUSE=""
-RDEPEND="media-libs/mesa
+RDEPEND="media-libs/mesa[motif]
x11-libs/openmotif
>=media-libs/jpeg-6b
>=media-libs/freetype-2.0
media-fonts/corefonts"
-DEPEND="dev-util/byacc
- ${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-util/byacc"
-S="${WORKDIR}/${MY_PN}"
-
-pkg_setup() {
- if ! built_with_use media-libs/mesa motif; then
- echo
- eerror "In order to compile openinventor, you need to have media-libs/mesa emerged"
- eerror "with 'motif' in your USE flags. Please add that flag, re-emerge"
- eerror "media-libs/mesa, and then emerge openinventor"
- die "media-libs/mesa is missing motif"
- fi
-}
+S=${WORKDIR}/${MY_PN}
src_unpack() {
unpack ${A}
@@ -57,6 +48,8 @@ src_unpack() {
# fix bug #251681
epatch "${FILESDIR}"/bug-251681.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+
# respect CC etc
sed -i \
-e "s:CC = /usr/bin/gcc:CC = $(tc-getCC):g" \