summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-06-07 08:57:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-06-07 08:57:46 +0000
commita5be94ad920ed2dc43d6ce63523965cb8887e525 (patch)
tree25f7f0feeb4cd867c866356689d3220ed9e85b8a /media-libs/openinventor
parentNew patch from Debian, fixes a few issue with cfortran (diff)
downloadgentoo-2-a5be94ad920ed2dc43d6ce63523965cb8887e525.tar.gz
gentoo-2-a5be94ad920ed2dc43d6ce63523965cb8887e525.tar.bz2
gentoo-2-a5be94ad920ed2dc43d6ce63523965cb8887e525.zip
Added a few trivial fixes for gcc-4.3 in gcc4-support.patch, and filter optimizations >=O2 because of segmentation faults
(Portage version: 2.1.5.4)
Diffstat (limited to 'media-libs/openinventor')
-rw-r--r--media-libs/openinventor/ChangeLog7
-rw-r--r--media-libs/openinventor/files/gcc4-support.patch95
-rw-r--r--media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild14
3 files changed, 110 insertions, 6 deletions
diff --git a/media-libs/openinventor/ChangeLog b/media-libs/openinventor/ChangeLog
index c9c32a27281e..5242f1c4a49d 100644
--- a/media-libs/openinventor/ChangeLog
+++ b/media-libs/openinventor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/openinventor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/ChangeLog,v 1.16 2008/05/23 16:32:55 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/ChangeLog,v 1.17 2008/06/07 08:57:45 bicatali Exp $
+
+ 07 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/gcc4-support.patch, openinventor-2.1.5.10-r2.ebuild:
+ Added a few trivial fixes for gcc-4.3 in gcc4-support.patch, and filter
+ optimizations >=O2 because of segmentation faults
23 May 2008; Markus Meier <maekke@gentoo.org>
openinventor-2.1.5.10-r2.ebuild:
diff --git a/media-libs/openinventor/files/gcc4-support.patch b/media-libs/openinventor/files/gcc4-support.patch
index 3f2c4af2b6dc..0ef963fde49e 100644
--- a/media-libs/openinventor/files/gcc4-support.patch
+++ b/media-libs/openinventor/files/gcc4-support.patch
@@ -101,3 +101,98 @@ diff -urN ./inventor-old/libSoXt/src/SoXtRsrc.c++ ./inventor/libSoXt/src/SoXtRsr
}
// make the last entry the NULL sentinel
+--- ./inventor-old/apps/demos/drop/drop.c++ 2008-06-06 10:44:36.000000000 +0100
++++ ./inventor/apps/demos/drop/drop.c++ 2008-06-04 15:22:05.000000000 +0100
+@@ -93,5 +93,6 @@
+ // Enter the Xt event loop
+ SoXt::show( appWindow );
+ SoXt::mainLoop();
++ return 0;
+ }
+
+--- ./inventor-old/apps/demos/maze/maze.c++ 2008-06-06 10:44:36.000000000 +0100
++++ ./inventor/apps/demos/maze/maze.c++ 2008-06-04 15:22:05.000000000 +0100
+@@ -1332,5 +1332,6 @@
+
+ SoXt::show(mainWindow);
+ SoXt::mainLoop();
++ return 0;
+ }
+
+--- ./inventor-old/apps/demos/noodle/noodle.c++ 2008-06-06 10:44:36.000000000 +0100
++++ ./inventor/apps/demos/noodle/noodle.c++ 2008-06-04 15:22:05.000000000 +0100
+@@ -679,5 +679,6 @@
+ SoXt::show(mainWindow);
+
+ SoXt::mainLoop();
++ return 0;
+ }
+
+--- ./inventor-old/apps/demos/SceneViewer/SceneViewer.c++ 2008-06-06 10:44:36.000000000 +0100
++++ ./inventor/apps/demos/SceneViewer/SceneViewer.c++ 2008-06-04 15:22:04.000000000 +0100
+@@ -230,4 +230,5 @@
+ // Loop forever
+ //
+ SoXt::mainLoop();
++ return 0;
+ }
+--- ./inventor-old/apps/samples/widgets/componentTest.c++ 2008-06-06 10:44:36.000000000 +0100
++++ ./inventor/apps/samples/widgets/componentTest.c++ 2008-06-04 15:22:05.000000000 +0100
+@@ -60,7 +60,7 @@
+ }
+
+ int
+-main(unsigned int argc, char *argv[])
++main(int argc, char *argv[])
+ {
+ if (argc != 2)
+ usage(argv[0]);
+@@ -85,4 +85,5 @@
+ XtRealizeWidget(mainWindow);
+
+ SoXt::mainLoop();
++ return 0;
+ }
+--- ./inventor-old/doc/man/ivman/ClassDef.c++ 2008-06-06 10:44:38.000000000 +0100
++++ ./inventor/doc/man/ivman/ClassDef.c++ 2008-06-04 15:22:05.000000000 +0100
+@@ -237,7 +237,7 @@
+
+ #define NUM_KEY_WORDS (sizeof(keywords) / sizeof(keywords[0]))
+
+- int i;
++ size_t i;
+
+ if (names == NULL) {
+ names = new SbName[NUM_KEY_WORDS];
+--- ./inventor-old/doc/man/ivman/Main.c++ 2008-06-06 10:44:38.000000000 +0100
++++ ./inventor/doc/man/ivman/Main.c++ 2008-06-04 15:22:05.000000000 +0100
+@@ -89,7 +89,7 @@
+ //
+ /////////////////////////////////////////////////////////////////////////////
+
+-main(int argc, char *argv[])
++int main(int argc, char *argv[])
+ {
+ SbBool ok = TRUE;
+ int c, curArg;
+--- ./inventor-old/doc/man/ivman/Man.c++ 2008-06-06 10:44:38.000000000 +0100
++++ ./inventor/doc/man/ivman/Man.c++ 2008-06-04 15:22:05.000000000 +0100
+@@ -806,7 +806,7 @@
+
+ #define NUM_OP_NAMES (sizeof(opNames) / sizeof(opNames[0]))
+
+- int op;
++ size_t op;
+ for (op = 0; op < NUM_OP_NAMES; op++) {
+ if (name == opNames[op][0]) {
+ name = opNames[op][1];
+--- ./inventor-old/doc/man/ivman/Man.h 2008-06-06 10:44:38.000000000 +0100
++++ ./inventor/doc/man/ivman/Man.h 2008-06-04 15:22:05.000000000 +0100
+@@ -131,6 +131,7 @@
+ virtual void write(SbBool runIn) = 0;
+ virtual SbBool read() = 0;
+ virtual int getNumPreTabChars() const;
++ virtual ~Item() {}
+ protected:
+ Item();
+ private:
diff --git a/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild b/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild
index aa784c5c076c..ad9e147b7cfd 100644
--- a/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild
+++ b/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild,v 1.7 2008/05/23 16:32:55 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild,v 1.8 2008/06/07 08:57:45 bicatali Exp $
-inherit eutils versionator
+inherit eutils versionator flag-o-matic
MY_PV=$(replace_version_separator 3 '-')
MY_PN="inventor"
@@ -17,9 +17,10 @@ KEYWORDS="alpha amd64 x86"
IUSE=""
RDEPEND="media-libs/mesa
- virtual/motif
+ x11-libs/openmotif
>=media-libs/jpeg-6b
- >=media-libs/freetype-2.0"
+ >=media-libs/freetype-2.0
+ media-fonts/corefonts"
DEPEND="dev-util/byacc
${RDEPEND}"
@@ -55,6 +56,9 @@ src_unpack() {
}
src_compile() {
+ # -O2 segfaults on amd64 gcc-4.3 with ivman command (bicatali jun.08)
+ replace-flags -O? -O1
+
# VLDOPTS: find libraries during linking of executables
# VLDDSOOPTS: find libraries during linking of libraries
# VCFLAGS / VCXXFLAGS: pass user-chosen compiler flags
@@ -80,7 +84,7 @@ src_install() {
# system
# IVLIBDIR: multilib-strict compliance
# LD_LIBRARY_PATH: support executables ran during install
- make \
+ emake -j1 \
IVROOT="${D}" \
LLDOPTS= \
IVLIBDIR="${D}usr/$(get_libdir)" \