summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-02-02 20:29:46 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-02-02 20:29:46 +0000
commit269d0ead267b9cf04cc0474046f5646f5ceac683 (patch)
tree96aef0753f8eabc2ed405eddf037894e40103f86 /media-libs/mesa
parentMark 2.12.0 stable on alpha (diff)
downloadgentoo-2-269d0ead267b9cf04cc0474046f5646f5ceac683.tar.gz
gentoo-2-269d0ead267b9cf04cc0474046f5646f5ceac683.tar.bz2
gentoo-2-269d0ead267b9cf04cc0474046f5646f5ceac683.zip
Add USE=debug support.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/ChangeLog5
-rw-r--r--media-libs/mesa/mesa-6.4.1-r1.ebuild15
2 files changed, 16 insertions, 4 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 030b3ccd8545..fe7bac10c391 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/mesa
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.61 2006/01/31 12:56:07 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.62 2006/02/02 20:29:46 spyderous Exp $
+
+ 02 Feb 2006; Donnie Berkholz <spyderous@gentoo.org>; mesa-6.4.1-r1.ebuild:
+ Add USE=debug support.
31 Jan 2006; Rene Nussbaumer <killerfox@gentoo.org> mesa-6.4.1-r1.ebuild:
Unstable on hppa.
diff --git a/media-libs/mesa/mesa-6.4.1-r1.ebuild b/media-libs/mesa/mesa-6.4.1-r1.ebuild
index d862a1347938..6eb5aee5a23d 100644
--- a/media-libs/mesa/mesa-6.4.1-r1.ebuild
+++ b/media-libs/mesa/mesa-6.4.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.4.1-r1.ebuild,v 1.5 2006/01/31 12:56:07 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-6.4.1-r1.ebuild,v 1.6 2006/02/02 20:29:46 spyderous Exp $
-inherit eutils toolchain-funcs multilib
+inherit eutils toolchain-funcs multilib flag-o-matic
# Arches that need to define their own sets of DRI drivers, please do so in
# a variable up here, and use that variable below. This helps us to separate the
@@ -20,7 +20,7 @@ SRC_URI="mirror://sourceforge/mesa3d/${MY_SRC_P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sh ~sparc ~x86"
-IUSE="motif"
+IUSE="debug motif"
RDEPEND="dev-libs/expat
x11-libs/libX11
@@ -45,7 +45,16 @@ S="${WORKDIR}/${MY_P}"
# Think about: ggi, svga, fbcon, no-X configs
+if use debug; then
+ RESTRICT="${RESTRICT} nostrip"
+fi
+
pkg_setup() {
+ if use debug; then
+ strip-flags
+ append-flags -ggdb
+ fi
+
if [[ ${KERNEL} == "FreeBSD" ]]; then
CONFIG="freebsd"
elif use x86; then