summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-12-05 23:27:56 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-12-05 23:27:56 +0000
commitaf93a818efdac526deefcd3bedc754266a59e195 (patch)
treea2c1e83804a7caa48d5900f5822983e2483bce8d /media-libs/mesa-glu
parentChanged install mode for sshd script to 755 (diff)
downloadgentoo-2-af93a818efdac526deefcd3bedc754266a59e195.tar.gz
gentoo-2-af93a818efdac526deefcd3bedc754266a59e195.tar.bz2
gentoo-2-af93a818efdac526deefcd3bedc754266a59e195.zip
new bash rev and a mesa-glu relocation
Diffstat (limited to 'media-libs/mesa-glu')
-rw-r--r--media-libs/mesa-glu/files/digest-mesa-glu-3.41
-rw-r--r--media-libs/mesa-glu/mesa-glu-3.2.1.ebuild39
-rw-r--r--media-libs/mesa-glu/mesa-glu-3.4.ebuild40
3 files changed, 80 insertions, 0 deletions
diff --git a/media-libs/mesa-glu/files/digest-mesa-glu-3.4 b/media-libs/mesa-glu/files/digest-mesa-glu-3.4
new file mode 100644
index 000000000000..5184b611227e
--- /dev/null
+++ b/media-libs/mesa-glu/files/digest-mesa-glu-3.4
@@ -0,0 +1 @@
+MD5 e88f755ed22b0377ee660bd82e2ad8b4 MesaLib-3.4.tar.gz
diff --git a/media-libs/mesa-glu/mesa-glu-3.2.1.ebuild b/media-libs/mesa-glu/mesa-glu-3.2.1.ebuild
new file mode 100644
index 000000000000..6c5b237ade30
--- /dev/null
+++ b/media-libs/mesa-glu/mesa-glu-3.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa-glu/mesa-glu-3.2.1.ebuild,v 1.1 2000/12/05 23:27:55 drobbins Exp $
+
+P=MesaLib-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/Mesa-${PV}
+DESCRIPTION="OpenGL like graphic library for Linux"
+SRC_URI="ftp://gd.tuwien.ac.at/graphics/libs/Mesa/${A}"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=x11-base/xfree-4.0.1"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr/X11R6 --sysconfdir=/etc/mesa --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ rm -f ${D}/usr/X11R6/lib/libGL.*
+
+ rm -f ${D}/usr/X11R6/include/GL/gl.h
+ rm -f ${D}/usr/X11R6/include/GL/glx.h
+ rm -f ${D}/usr/X11R6/include/GL/osmesa.h
+ cd ${D}/usr/X11R6/lib
+ ln -s libGLU.so.1.1.030201 libMesaGLU.so.3
+
+ cd ${S}
+ dodoc docs/*
+}
+
diff --git a/media-libs/mesa-glu/mesa-glu-3.4.ebuild b/media-libs/mesa-glu/mesa-glu-3.4.ebuild
new file mode 100644
index 000000000000..950d49ceba61
--- /dev/null
+++ b/media-libs/mesa-glu/mesa-glu-3.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa-glu/mesa-glu-3.4.ebuild,v 1.1 2000/12/05 23:27:55 drobbins Exp $
+
+P=MesaLib-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/Mesa-${PV}
+DESCRIPTION="OpenGL like graphic library for Linux"
+SRC_URI="ftp://gd.tuwien.ac.at/graphics/libs/Mesa/${A}"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=x11-base/xfree-4.0.1"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr/X11R6 --sysconfdir=/etc/mesa --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+# rm -f ${D}/usr/X11R6/lib/libGL.*
+
+# rm -f ${D}/usr/X11R6/include/GL/gl.h
+# rm -f ${D}/usr/X11R6/include/GL/glx.h
+# rm -f ${D}/usr/X11R6/include/GL/osmesa.h
+ cd ${D}/usr/X11R6/lib
+ ln -s libGLU.so.1.1.030400 libMesaGLU.so.3
+ ln -s libGL.so.2.1.030400 libMesaGL.so.3
+
+ cd ${S}
+ dodoc docs/*
+}
+