summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-23 17:22:11 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-23 17:22:11 +0000
commit731e65fa86203bf32851ff3c1f288e3968fa1aee (patch)
treecce1b365323fb9b7e6bb3435f3da6b1d9b211eef /media-libs/mesa-glu
parentDisabled pam support cuz it does not work atm (diff)
downloadgentoo-2-731e65fa86203bf32851ff3c1f288e3968fa1aee.tar.gz
gentoo-2-731e65fa86203bf32851ff3c1f288e3968fa1aee.tar.bz2
gentoo-2-731e65fa86203bf32851ff3c1f288e3968fa1aee.zip
New version with glu-1.3
Diffstat (limited to 'media-libs/mesa-glu')
-rw-r--r--media-libs/mesa-glu/files/digest-mesa-glu-3.52
-rw-r--r--media-libs/mesa-glu/mesa-glu-3.5.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/media-libs/mesa-glu/files/digest-mesa-glu-3.5 b/media-libs/mesa-glu/files/digest-mesa-glu-3.5
new file mode 100644
index 000000000000..24e4500466a0
--- /dev/null
+++ b/media-libs/mesa-glu/files/digest-mesa-glu-3.5
@@ -0,0 +1,2 @@
+MD5 270e82cf8c0f7fd878a5620755fe0b6c MesaLib-3.5.tar.bz2
+MD5 505562ff17f3d946296df9100a798f42 MesaDemos-3.5.tar.bz2
diff --git a/media-libs/mesa-glu/mesa-glu-3.5.ebuild b/media-libs/mesa-glu/mesa-glu-3.5.ebuild
new file mode 100644
index 000000000000..a3a47664bc65
--- /dev/null
+++ b/media-libs/mesa-glu/mesa-glu-3.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa-glu/mesa-glu-3.5.ebuild,v 1.1 2001/06/23 17:22:11 achim Exp $
+
+P=MesaLib-${PV}
+A0=${P}.tar.bz2
+A1=MesaDemos-${PV}.tar.bz2
+A="${A0} ${A1}"
+S=${WORKDIR}/Mesa-${PV}
+DESCRIPTION="OpenGL like graphic library for Linux, this package only contains the glu and glut parts"
+SRC_URI="http://download.sourceforge.net/mesa3d/${A0}
+ http://download.sourceforge.net/mesa3d/${A1}"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+DEPEND="virtual/glibc virtual/x11"
+
+PROVIDE="virtual/glu virtual/glut"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/si-glu/include
+ ln -s ../../include/GL GL
+}
+
+src_compile() {
+
+ local myconf
+
+ if [ "`use mmx`" ]
+ then
+ myconf="--enable-mmx"
+ else
+ myconf="--disable-mmx"
+ fi
+
+ if [ "`use 3dnow`" ]
+ then
+ myconf="${myconf} --enable-3dnow"
+ else
+ myconf="${myconf} --disable-3dnow"
+ fi
+
+ if [ "`use sse`" ]
+ then
+ myconf="${myconf} --enable-sse"
+ else
+ myconf="${myconf} --disable-sse"
+ fi
+
+ myconf="${myconf} --with-x --without-glut --disable-ggi-fbdev --without-ggi"
+
+ try ./configure --prefix=/usr --sysconfdir=/etc/mesa --host=${CHOST} $myconf
+
+ try make
+
+}
+
+src_install () {
+
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ cd ${D}/usr/lib
+
+ rm -f libGL.*
+
+ rm -f ../include/GL/gl.h
+ rm -f ../include/GL/glx.h
+ rm -f ../include/GL/osmesa.h
+
+ ln -s libGLU.so.1.3.350 libMesaGLU.so.3
+
+
+ cd ${S}
+ dodoc docs/*
+}
+