summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-02 08:06:17 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-10-02 08:06:17 +0000
commitf21dcbd58978c835a425a044e3407c6559863a42 (patch)
tree231f1ad8d8e269397235acebc446747ca9857973 /media-libs/libtheora
parentadd freealut dep; fix wrapper (bug #149589) (diff)
downloadgentoo-2-f21dcbd58978c835a425a044e3407c6559863a42.tar.gz
gentoo-2-f21dcbd58978c835a425a044e3407c6559863a42.tar.bz2
gentoo-2-f21dcbd58978c835a425a044e3407c6559863a42.zip
Version bump, hoping it works.
(Portage version: 2.1.2_pre2-r1)
Diffstat (limited to 'media-libs/libtheora')
-rw-r--r--media-libs/libtheora/ChangeLog8
-rw-r--r--media-libs/libtheora/files/digest-libtheora-1.0_alpha73
-rw-r--r--media-libs/libtheora/libtheora-1.0_alpha7.ebuild63
3 files changed, 73 insertions, 1 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index 924c77d420c6..dcdd0a0e560f 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libtheora
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.47 2006/09/04 05:29:27 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.48 2006/10/02 08:06:17 flameeyes Exp $
+
+*libtheora-1.0_alpha7 (02 Oct 2006)
+
+ 02 Oct 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +libtheora-1.0_alpha7.ebuild:
+ Version bump, hoping it works.
04 Sep 2006; Joshua Kinard <kumba@gentoo.org>
libtheora-1.0_alpha6-r1.ebuild:
diff --git a/media-libs/libtheora/files/digest-libtheora-1.0_alpha7 b/media-libs/libtheora/files/digest-libtheora-1.0_alpha7
new file mode 100644
index 000000000000..50381fb22b98
--- /dev/null
+++ b/media-libs/libtheora/files/digest-libtheora-1.0_alpha7
@@ -0,0 +1,3 @@
+MD5 1bc851e39e4b16977131d5e5f769f48b libtheora-1.0alpha7.tar.bz2 1673255
+RMD160 45a46c35cb1bd6f44a82a286940937e031edb14f libtheora-1.0alpha7.tar.bz2 1673255
+SHA256 f0380bedd14382cf80304e3f209704b460a87981cd11e32194d940151d8880ea libtheora-1.0alpha7.tar.bz2 1673255
diff --git a/media-libs/libtheora/libtheora-1.0_alpha7.ebuild b/media-libs/libtheora/libtheora-1.0_alpha7.ebuild
new file mode 100644
index 000000000000..b6b1f152850f
--- /dev/null
+++ b/media-libs/libtheora/libtheora-1.0_alpha7.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.0_alpha7.ebuild,v 1.1 2006/10/02 08:06:17 flameeyes Exp $
+
+inherit flag-o-matic libtool autotools
+
+DESCRIPTION="The Theora Video Compression Codec"
+HOMEPAGE="http://www.theora.org/"
+SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
+
+LICENSE="xiph"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ia64 mips ppc ~ppc-macos ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="encode doc examples"
+
+RDEPEND=">=media-libs/libogg-1.1.0
+ encode? ( >=media-libs/libvorbis-1.0.1 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e 's:SUBDIRS = .*:SUBDIRS = lib include doc:' Makefile.am
+
+ elibtoolize
+
+ if use examples; then
+ # This creates a clean copy of examples sources
+ cp -R "${S}/examples" "${WORKDIR}"
+ rm -f "${WORKDIR}/examples/Makefile"*
+ fi
+}
+
+src_compile() {
+ # bug #75403, -O3 needs to be filtered to -O2
+ replace-flags -O3 -O2
+
+ use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
+
+ econf \
+ $(use_enable encode) \
+ --enable-shared \
+ --disable-dependency-tracking \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="usr/share/doc/${PF}" \
+ install || die "make install failed"
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins "${WORKDIR}/examples/"*
+ fi
+
+ dodoc README
+}