summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-22 03:02:35 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-22 03:02:35 +0000
commit8616f292c34c2e21f220d779c9fe49996d6e34d7 (patch)
treee9b0721e5cd089409930eca65a3ebfedae8c8379 /media-libs/libraw
parentRemove python 3.3 until socketpool catches up (diff)
downloadgentoo-2-8616f292c34c2e21f220d779c9fe49996d6e34d7.tar.gz
gentoo-2-8616f292c34c2e21f220d779c9fe49996d6e34d7.tar.bz2
gentoo-2-8616f292c34c2e21f220d779c9fe49996d6e34d7.zip
Version bump.
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-libs/libraw')
-rw-r--r--media-libs/libraw/ChangeLog7
-rw-r--r--media-libs/libraw/libraw-0.14.8.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/media-libs/libraw/ChangeLog b/media-libs/libraw/ChangeLog
index 8d2d6c415bf1..e99be35a1309 100644
--- a/media-libs/libraw/ChangeLog
+++ b/media-libs/libraw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libraw
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.48 2013/02/16 02:30:03 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.49 2013/05/22 03:02:35 radhermit Exp $
+
+*libraw-0.14.8 (22 May 2013)
+
+ 22 May 2013; Tim Harder <radhermit@gentoo.org> +libraw-0.14.8.ebuild:
+ Version bump.
*libraw-0.15.0_beta4 (16 Feb 2013)
diff --git a/media-libs/libraw/libraw-0.14.8.ebuild b/media-libs/libraw/libraw-0.14.8.ebuild
new file mode 100644
index 000000000000..9fdaa7cc408f
--- /dev/null
+++ b/media-libs/libraw/libraw-0.14.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/libraw-0.14.8.ebuild,v 1.1 2013/05/22 03:02:35 radhermit Exp $
+
+EAPI="5"
+
+inherit eutils autotools toolchain-funcs
+
+MY_P="LibRaw-${PV}"
+DESCRIPTION="LibRaw is a library for reading RAW files obtained from digital photo cameras"
+HOMEPAGE="http://www.libraw.org/"
+SRC_URI="http://www.libraw.org/data/${MY_P}.tar.gz
+ demosaic? ( http://www.libraw.org/data/LibRaw-demosaic-pack-GPL2-${PV}.tar.gz
+ http://www.libraw.org/data/LibRaw-demosaic-pack-GPL3-${PV}.tar.gz )"
+
+# Libraw also has it's own license, which is a pdf file and
+# can be obtained from here:
+# http://www.libraw.org/data/LICENSE.LibRaw.pdf
+LICENSE="LGPL-2.1 CDDL GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="demosaic examples jpeg2k +lcms openmp static-libs"
+
+RDEPEND="jpeg2k? ( media-libs/jasper )
+ lcms? ( media-libs/lcms:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( Changelog.txt README )
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.4-docs.patch
+ epatch "${FILESDIR}"/${PN}-0.14.7-pkgconfig.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable demosaic demosaic-pack-gpl2) \
+ $(use_enable demosaic demosaic-pack-gpl3) \
+ $(use_enable examples) \
+ $(use_enable jpeg2k jasper) \
+ $(use_enable lcms) \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}