summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-16 00:27:30 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-16 00:27:30 +0000
commit972f91cf971275d90c0e396ff554ff43a2cf2764 (patch)
tree9edc8a01777616166ab0bc4e1e9b0fc8a5b70ad7 /media-libs/libquicktime/libquicktime-0.9.7-r1.ebuild
parentMarked ppc stable for bug #103253. (diff)
downloadgentoo-2-972f91cf971275d90c0e396ff554ff43a2cf2764.tar.gz
gentoo-2-972f91cf971275d90c0e396ff554ff43a2cf2764.tar.bz2
gentoo-2-972f91cf971275d90c0e396ff554ff43a2cf2764.zip
New revision with patch to disable libdv support as per bug #108570. Also, add X useflag to be able to build without X.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'media-libs/libquicktime/libquicktime-0.9.7-r1.ebuild')
-rw-r--r--media-libs/libquicktime/libquicktime-0.9.7-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/media-libs/libquicktime/libquicktime-0.9.7-r1.ebuild b/media-libs/libquicktime/libquicktime-0.9.7-r1.ebuild
new file mode 100644
index 000000000000..13ee29337561
--- /dev/null
+++ b/media-libs/libquicktime/libquicktime-0.9.7-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libquicktime/libquicktime-0.9.7-r1.ebuild,v 1.1 2005/10/16 00:27:30 flameeyes Exp $
+
+inherit libtool eutils autotools
+
+DESCRIPTION="A library based on quicktime4linux with extensions"
+HOMEPAGE="http://libquicktime.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="gtk jpeg mmx vorbis png dv ieee1394 X"
+
+DEPEND=">=sys-apps/sed-4.0.5
+ dv? ( media-libs/libdv )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ vorbis? ( media-libs/libvorbis )
+ ieee1394? (
+ sys-libs/libavc1394
+ sys-libs/libraw1394
+ )
+ X? ( virtual/x11 )
+ !virtual/quicktime"
+PROVIDE="virtual/quicktime"
+
+pkg_setup() {
+ if has_version x11-base/xorg-x11 && ! built_with_use x11-base/xorg-x11 opengl; then
+ die "You need xv support to compile ${PN}."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ sed -i "s:\(have_libavcodec=\)true:\1false:g" configure.ac
+ epatch "${FILESDIR}/${P}-dv.patch"
+
+ eautoconf
+ elibtoolize
+}
+
+src_compile() {
+ econf --enable-shared \
+ --enable-static \
+ $(use_enable mmx) \
+ $(use_enable gtk) \
+ $(use_enable ieee1394 firewire) \
+ $(use_with dv libdv) \
+ $(use_with X x)
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dosym /usr/include/lqt /usr/include/quicktime
+}