summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-08 13:27:52 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-08 13:27:52 +0000
commit480fa6f650482e5609e49ebf56bb9a5bcc177dd8 (patch)
tree5a66f5860661ec4884783a08e4fb6a9c94ebf479 /media-libs/libpng
parent*** empty log message *** (diff)
downloadgentoo-2-480fa6f650482e5609e49ebf56bb9a5bcc177dd8.tar.gz
gentoo-2-480fa6f650482e5609e49ebf56bb9a5bcc177dd8.tar.bz2
gentoo-2-480fa6f650482e5609e49ebf56bb9a5bcc177dd8.zip
*** empty log message ***
Diffstat (limited to 'media-libs/libpng')
-rw-r--r--media-libs/libpng/files/digest1
-rw-r--r--media-libs/libpng/libpng-1.0.8-r1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/libpng/files/digest b/media-libs/libpng/files/digest
new file mode 100644
index 000000000000..f3164c077fdb
--- /dev/null
+++ b/media-libs/libpng/files/digest
@@ -0,0 +1 @@
+MD5 5ac355d7ec9e27f20bfe00aa10f9fdde libpng-1.0.8.tar.gz
diff --git a/media-libs/libpng/libpng-1.0.8-r1.ebuild b/media-libs/libpng/libpng-1.0.8-r1.ebuild
new file mode 100644
index 000000000000..210b51c361e4
--- /dev/null
+++ b/media-libs/libpng/libpng-1.0.8-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/libpng-1.0.8-r1.ebuild,v 1.1 2000/08/08 13:24:41 achim Exp $
+
+P=libpng-1.0.8
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="libpng"
+CATEGORY=media-libs
+SRC_URI="http://www.libpng.org/pub/png/src/${P}.tar.gz"
+HOMEPAGE="http://www.libpng.org/"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+}
+
+src_compile() {
+ cd ${S}
+ sed -e "s:ZLIBLIB=../zlib:ZLIBLIB=/usr/lib:" \
+ -e "s:ZLIBINC=../zlib:ZLIBINC=/usr/include:" \
+ -e "s:prefix=/usr:prefix=${D}/usr:" \
+ -e "s/-O3/${CFLAGS}/" \
+ scripts/makefile.linux > Makefile
+ make
+}
+
+
+src_install() {
+ cd ${S}
+ mkdir ${D}/usr
+ mkdir ${D}/usr/include
+ mkdir ${D}/usr/lib
+ make install prefix=${D}/usr
+ into /usr
+ doman *.3 *.5
+ dodoc ANNOUNCE CHANGES KNOWNBUG LICENSE README TODO Y2KINFO
+}