summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-09-30 17:39:46 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-09-30 17:39:46 +0000
commit1a41e99674a8aab1b7938a8a642d14be3605b935 (patch)
treeb7cd23ddb60fa0cd126fae6828e60e30d2af6d9a /media-libs/libogg/libogg-1.1.2.ebuild
parenthal added to use.mask (diff)
downloadgentoo-2-1a41e99674a8aab1b7938a8a642d14be3605b935.tar.gz
gentoo-2-1a41e99674a8aab1b7938a8a642d14be3605b935.tar.bz2
gentoo-2-1a41e99674a8aab1b7938a8a642d14be3605b935.zip
Version bump closes bug #65865.
Diffstat (limited to 'media-libs/libogg/libogg-1.1.2.ebuild')
-rw-r--r--media-libs/libogg/libogg-1.1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libogg/libogg-1.1.2.ebuild b/media-libs/libogg/libogg-1.1.2.ebuild
new file mode 100644
index 000000000000..fc50f990aae0
--- /dev/null
+++ b/media-libs/libogg/libogg-1.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libogg/libogg-1.1.2.ebuild,v 1.1 2004/09/30 17:39:46 eradicator Exp $
+
+IUSE=""
+
+inherit gnuconfig
+
+DESCRIPTION="the Ogg media file format library"
+HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+SRC_URI="http://downloads.xiph.org/releases/ogg/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~mips ~ia64 ~ppc64 ~macos ~ppc-macos"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ gnuconfig_update
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # remove the docs installed by make install, since I'll install
+ # them in portage package doc directory
+ rm -rf "${D}/usr/share/doc"
+
+ dodoc AUTHORS CHANGES README
+ dohtml doc/*.{html,png}
+}