summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-02-27 19:38:42 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-02-27 19:38:42 +0000
commitd6d2d7e0f024981338cb4fab1b12e5aef78ad767 (patch)
tree0413712ddf51c6821af6d743c81fc291ce1ceb6a /media-libs/libmpeg3
parentmove the filter-flags statement into src_compile (Manifest recommit) (diff)
downloadgentoo-2-d6d2d7e0f024981338cb4fab1b12e5aef78ad767.tar.gz
gentoo-2-d6d2d7e0f024981338cb4fab1b12e5aef78ad767.tar.bz2
gentoo-2-d6d2d7e0f024981338cb4fab1b12e5aef78ad767.zip
move the filter-flags statement into src_compile
Diffstat (limited to 'media-libs/libmpeg3')
-rw-r--r--media-libs/libmpeg3/ChangeLog6
-rw-r--r--media-libs/libmpeg3/libmpeg3-1.5-r1.ebuild26
-rw-r--r--media-libs/libmpeg3/libmpeg3-1.5.1.ebuild18
3 files changed, 27 insertions, 23 deletions
diff --git a/media-libs/libmpeg3/ChangeLog b/media-libs/libmpeg3/ChangeLog
index 214818612785..c528c3b98117 100644
--- a/media-libs/libmpeg3/ChangeLog
+++ b/media-libs/libmpeg3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libmpeg3
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/ChangeLog,v 1.19 2004/01/29 04:09:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/ChangeLog,v 1.20 2004/02/27 19:36:06 seemant Exp $
+
+ 27 Feb 2004; Seemant Kulleen <seemant@gentoo.org> libmpeg3-1.5-r1.ebuild,
+ libmpeg3-1.5.1.ebuild:
+ move the filter-flags statement into src_compile
28 Jan 2004; Aron Griffis <agriffis@gentoo.org> libmpeg3-1.5.2.ebuild:
stable on ia64
diff --git a/media-libs/libmpeg3/libmpeg3-1.5-r1.ebuild b/media-libs/libmpeg3/libmpeg3-1.5-r1.ebuild
index fd6578e28993..cb6b471d5cd3 100644
--- a/media-libs/libmpeg3/libmpeg3-1.5-r1.ebuild
+++ b/media-libs/libmpeg3/libmpeg3-1.5-r1.ebuild
@@ -1,32 +1,24 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.5-r1.ebuild,v 1.20 2003/09/06 23:59:48 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.5-r1.ebuild,v 1.21 2004/02/27 19:36:06 seemant Exp $
inherit flag-o-matic
+S=${WORKDIR}/${PN}
DESCRIPTION="An mpeg library for linux"
HOMEPAGE="http://heroinewarrior.com/libmpeg3.php3"
SRC_URI="http://heroinewarrior.com/${P}.tar.gz"
-LICENSE="GPL-2"
SLOT="0"
+LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc alpha hppa amd64"
RDEPEND="sys-libs/zlib
media-libs/jpeg"
+
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
-S=${WORKDIR}/${PN}
-
-filter-flags -fPIC
-filter-flags -fno-common
-[ $ARCH = alpha ] && append-flags -fPIC
-[ $ARCH = hppa ] && append-flags -fPIC
-[ $ARCH = amd64 ] && append-flags -fPIC
-# http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
-has_version 'sys-devel/hardened-gcc' && append-flags '-yet_exec'
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -38,6 +30,14 @@ src_unpack() {
}
src_compile() {
+ filter-flags -fPIC
+ filter-flags -fno-common
+ [ $ARCH = alpha ] && append-flags -fPIC
+ [ $ARCH = hppa ] && append-flags -fPIC
+ [ $ARCH = amd64 ] && append-flags -fPIC
+ # http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
+ has_version 'sys-devel/hardened-gcc' && append-flags '-yet_exec'
+
make || die
}
diff --git a/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild b/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild
index 1b5af8d38ae2..330211b7c6ac 100644
--- a/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild
+++ b/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild,v 1.4 2003/09/06 12:58:10 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg3/libmpeg3-1.5.1.ebuild,v 1.5 2004/02/27 19:36:06 seemant Exp $
inherit flag-o-matic
@@ -17,13 +17,6 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm ) "
-filter-flags -fPIC
-filter-flags -fno-common
-[ ${ARCH} = alpha ] && append-flags -fPIC
-[ ${ARCH} = hppa ] && append-flags -fPIC
-# http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
-has_version 'sys-devel/hardened-gcc' && append-flags '-yet_exec'
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -39,6 +32,13 @@ src_unpack() {
}
src_compile() {
+ filter-flags -fPIC
+ filter-flags -fno-common
+ [ ${ARCH} = alpha ] && append-flags -fPIC
+ [ ${ARCH} = hppa ] && append-flags -fPIC
+ # http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
+ has_version 'sys-devel/hardened-gcc' && append-flags '-yet_exec'
+
make || die
}