summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-06 15:28:59 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-06 15:28:59 +0000
commitc59b0270acfe345bf398761771d58a964e2772e0 (patch)
treef98564b6cb24aadeb0c7fc05d5f50db25995100d /media-libs/libirman
parentDrop virtual/libc dependency. (diff)
downloadgentoo-2-c59b0270acfe345bf398761771d58a964e2772e0.tar.gz
gentoo-2-c59b0270acfe345bf398761771d58a964e2772e0.tar.bz2
gentoo-2-c59b0270acfe345bf398761771d58a964e2772e0.zip
Drop virtual/libc dependency, add patch to build with gcc4 and avoid problems with printf() calls, use the right compiler and linker.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'media-libs/libirman')
-rw-r--r--media-libs/libirman/ChangeLog10
-rw-r--r--media-libs/libirman/files/libirman-0.4.2-format.patch13
-rw-r--r--media-libs/libirman/files/libirman-0.4.2-gcc4.patch13
-rw-r--r--media-libs/libirman/libirman-0.4.2-r1.ebuild24
-rw-r--r--media-libs/libirman/metadata.xml2
5 files changed, 47 insertions, 15 deletions
diff --git a/media-libs/libirman/ChangeLog b/media-libs/libirman/ChangeLog
index a01b950aa1e3..d00b52f9c461 100644
--- a/media-libs/libirman/ChangeLog
+++ b/media-libs/libirman/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libirman
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libirman/ChangeLog,v 1.15 2005/09/03 23:36:27 flameeyes Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libirman/ChangeLog,v 1.16 2006/03/06 15:28:59 flameeyes Exp $
+
+ 06 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/libirman-0.4.2-format.patch, +files/libirman-0.4.2-gcc4.patch,
+ metadata.xml, libirman-0.4.2-r1.ebuild:
+ Drop virtual/libc dependency, add patch to build with gcc4 and avoid
+ problems with printf() calls, use the right compiler and linker.
03 Sep 2005; Diego Pettenò <flameeyes@gentoo.org>
libirman-0.4.2-r1.ebuild:
diff --git a/media-libs/libirman/files/libirman-0.4.2-format.patch b/media-libs/libirman/files/libirman-0.4.2-format.patch
new file mode 100644
index 000000000000..ee1c4f5cfe74
--- /dev/null
+++ b/media-libs/libirman/files/libirman-0.4.2-format.patch
@@ -0,0 +1,13 @@
+Index: libirman-0.4.2/workmanir.c
+===================================================================
+--- libirman-0.4.2.orig/workmanir.c
++++ libirman-0.4.2/workmanir.c
+@@ -148,7 +148,7 @@ int main(int argc, char **argv)
+
+ errno = 0;
+ if (ir_init(filename) < 0) {
+- fprintf(stderr, "%s: error initialising Irman: `%s'\n", ir_strerror(errno));
++ fprintf(stderr, "%s: error initialising Irman: `%s'\n", progname, ir_strerror(errno));
+ exit(1);
+ }
+
diff --git a/media-libs/libirman/files/libirman-0.4.2-gcc4.patch b/media-libs/libirman/files/libirman-0.4.2-gcc4.patch
new file mode 100644
index 000000000000..4c21df4a7a2a
--- /dev/null
+++ b/media-libs/libirman/files/libirman-0.4.2-gcc4.patch
@@ -0,0 +1,13 @@
+Index: libirman-0.4.2/chunk.c
+===================================================================
+--- libirman-0.4.2.orig/chunk.c
++++ libirman-0.4.2/chunk.c
+@@ -122,7 +122,7 @@ void *ch_malloc(size_t numbytes, chunk_t
+
+ ptr = ch->top;
+ ch->free -= numbytes;
+- (char *)ch->top += numbytes;
++ ch->top = (char*)(ch->top) + numbytes;
+
+ return ptr;
+ }
diff --git a/media-libs/libirman/libirman-0.4.2-r1.ebuild b/media-libs/libirman/libirman-0.4.2-r1.ebuild
index 4e468e2c9d55..0dc47742bfa5 100644
--- a/media-libs/libirman/libirman-0.4.2-r1.ebuild
+++ b/media-libs/libirman/libirman-0.4.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libirman/libirman-0.4.2-r1.ebuild,v 1.7 2005/09/03 23:36:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libirman/libirman-0.4.2-r1.ebuild,v 1.8 2006/03/06 15:28:59 flameeyes Exp $
IUSE=""
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="library for Irman control of Unix software"
SRC_URI="http://www.lirc.org/software/snapshots/${P}.tar.gz"
@@ -13,29 +13,29 @@ SLOT="0"
LICENSE="GPL-2 LGPL-2"
KEYWORDS="alpha amd64 ia64 ~ppc sparc x86"
-DEPEND="virtual/libc"
-
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-PICShared.patch
- epatch ${FILESDIR}/${P}-destdir.patch
+ epatch "${FILESDIR}/${P}-PICShared.patch"
+ epatch "${FILESDIR}/${P}-destdir.patch"
+ epatch "${FILESDIR}/${P}-format.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
}
src_compile() {
- econf || die
+ tc-export CC LD AR RANLIB
- # See bug #52586 for -j1 reasons
- emake -j1 || die
+ econf || die "econf failed"
+ emake -j1 || die "emake failed"
}
src_install() {
dodir /usr/include
make DESTDIR="${D}" \
- LIRC_DRIVER_DEVICE="${D}/dev/lirc" \
- install || die
+ LIRC_DRIVER_DEVICE="${D}/dev/lirc" \
+ install || die
dobin test_func test_io test_name
dodoc NEWS README* TECHNICAL TODO
diff --git a/media-libs/libirman/metadata.xml b/media-libs/libirman/metadata.xml
index 8af03839ffc3..e1774e3d9ad7 100644
--- a/media-libs/libirman/metadata.xml
+++ b/media-libs/libirman/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sound</herd>
+<herd>sound</herd>
</pkgmetadata>