summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-29 00:33:23 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-29 00:33:23 +0000
commitaa7d0ccbd64b09035cdf036e83ff6384261e1fb5 (patch)
tree80ccc63378b092ce9ef330fc36569e81ab221166 /media-libs/libfame/libfame-0.9.1-r1.ebuild
parentCleaning and bumping (diff)
downloadgentoo-2-aa7d0ccbd64b09035cdf036e83ff6384261e1fb5.tar.gz
gentoo-2-aa7d0ccbd64b09035cdf036e83ff6384261e1fb5.tar.bz2
gentoo-2-aa7d0ccbd64b09035cdf036e83ff6384261e1fb5.zip
fix aclocal warnings
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'media-libs/libfame/libfame-0.9.1-r1.ebuild')
-rw-r--r--media-libs/libfame/libfame-0.9.1-r1.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/media-libs/libfame/libfame-0.9.1-r1.ebuild b/media-libs/libfame/libfame-0.9.1-r1.ebuild
index d332b5b852a2..7d6e492e6e84 100644
--- a/media-libs/libfame/libfame-0.9.1-r1.ebuild
+++ b/media-libs/libfame/libfame-0.9.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.9.1-r1.ebuild,v 1.1 2005/04/25 15:39:27 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.9.1-r1.ebuild,v 1.2 2005/04/29 00:28:46 vapier Exp $
-inherit flag-o-matic gnuconfig gcc eutils
+inherit flag-o-matic gcc eutils
DESCRIPTION="MPEG-1 and MPEG-4 video encoding library"
HOMEPAGE="http://fame.sourceforge.net/"
@@ -13,29 +13,26 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="mmx sse"
-DEPEND="virtual/libc"
+DEPEND=""
src_unpack() {
unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-m4.patch
- cd ${S}
# Do not add -march=i586, bug #41770.
sed -i -e 's:-march=i[345]86 ::g' configure
#closing bug #45736
if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
then
- epatch ${FILESDIR}/${P}-mmx_configure.patch
- epatch ${FILESDIR}/${P}-gcc34.patch
+ epatch "${FILESDIR}"/${P}-mmx_configure.patch
+ epatch "${FILESDIR}"/${P}-gcc34.patch
fi
# yet another pic patch, thanks to the 'pic gods' ;-)
# see #90318
- epatch ${FILESDIR}/${P}-pic.patch
-
- # This is needed for alpha and probably other newer arches (amd64)
- # (13 Jan 2004 agriffis)
- gnuconfig_update
+ epatch "${FILESDIR}"/${P}-pic.patch
}
src_compile() {